BMW Werkz banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My 530i wont start after I left the lights on all night. I tried to jump it but no success. I took the battery to advanced and was told I had a bad battery. After putting in the new battery I still could not get it started. I changed the spark plugs because the old ones were flooded but still it will not run. I check the engine faults by the check engine light method and all checks out fine. I checked each spark plug for fire and that was good. I pulled the new sparks and they were also wet with gas. I checked the fuses and all are good. The fuseble link is good. the battery is clean and tight. the engine starts without a sputter to even show me that it's trying to fire. When I was trying to jump it it was trying to fire but now nothing. Just a rotating engine. Shouls i spray sarting fuid in the cylinders? All or one? I smell fuel but am not sure if the pump is running. I loosened a fuel hose and fuel was spraying. I hear the relays clicking but do not know witch one is the fuel or main relay. I need help. Does the fuel pump give a distinct hum or what? I tried to listen to it but with my ear to it in the trunk I can tell the sound through the sound of cranking the engine. Please help!!!!!
 

·
Registered
Joined
·
1,165 Posts
DO NOT I REPEAT DO NOT SPRAY STARTING FLUID INTO THAT ENGINE!!! chances are youll fuck it up.

so its cranking but not running? possible DIS problem..
 
1 - 2 of 2 Posts
Top