BMW Werkz banner
1 - 15 of 15 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Dear all,

I have a 1999 328i with 94,000 mileage. I came to a red light and stopped for a few seconds then the engine turned off itself. I switched the key to 0 and started the car again and everything was back to normal. Please advise on this urgent matter.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
Nothing is wrong with transmission, I changed the transmission fluid at 89,000. Lifetime oil my butt. Any other possibility? If there's something wrong with the transmission, why would it stop the engine? I don't see how that relates.
 

· Registered
Joined
·
16 Posts
I was having transmission problems and one day driving i came to a sudden stop and the car shut down, at first i panicked thinking the timing chain broke, but i tried to turn it on and it ran just fine, soon after i took it in to get the tranny fluid changed and after that the car did that no longer after sudden stops, this worked for me, but could be different in your case.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
i took the car to an auto shop that i know quite long and they used a computer to see what the problem was. it turned out that the CODE001 appeared and reads "Signal, inlet-camshaft sensor (OBDII:p0340; EUIII: PO340) The mechanic recommended to clean out some hoses first... i forgot what the technical term is. If that doesn't work, then i'll have to replace the sensor which he told me it'll cost me 300-400. so we'll see from there. keep you updated.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top