BMW Werkz banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
The radio (including cassette etc.) in this 7 series does not turn on at all. We jumped the car a few days ago but don't know if this would caused a problem (everything else is fine). This car has navigation which is working. So we are told that radios with navigation do not have any codes. Any ideas or suggestions to get the radio going again? Would really appreciate it.

Thanks
 

·
Registered
Joined
·
434 Posts
Check fuses. If it's an E38, there are fuses in the ebox under the hood, as well as some in the right rear of the trunk.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Yes it is an E38. I checked the radio fuse under the hood and in the trunk. Both are good. I am told there is a fuse in the back of the radio unit. Is this true? and if so, is it easy to pull the unit out to get to this fuse?
Thanks.
 

·
Registered
Joined
·
497 Posts
I would avoid using a test light on a BMW, especially late models. A multimeter would be a beter and much more advisable choice. Check your voltage on both sides of the fuses. Sometimes those fuses can look ok but are actually bad.
 

·
Registered
Joined
·
1 Posts
What year is the car? There should be a fuse next to the wiring harness in the back of the reciever. Is this the three part radio (reciever, eq, & MID). I had some problems with my radio too. when you turn your headlights on, do the buttons iluminate? I thought i'd lost power, but this wasn't the case, it sees to have been some kind of software related malfunction. I'm not sure about the security system, but you might be able to restore function simply by removing and reinstaling the radion components. I'm not sure what else to think.

Noah
 
1 - 8 of 8 Posts
Top