BMW Werkz banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I'm having some problems with my 3-series and the garage won't take it before 2 weeks time, can anyone help?

When I run the car the light indicating overheating comes on. The engine gets hot at the front and it can take up to 2 hours to cool back down again. The fluid level is ok, the oil indicator light hasn't come on, and the fan is working properly.
The airconditioning unit will only blow out cold air.

I've been told it could be a blockage somewhere, but how could I check this?

Thanks
 

·
Registered
Joined
·
165 Posts
the plastic impeller has probably separated from the waterpump shaft. very common problem. don't drive the car, have it towed or you run the risk of damaging the engine. hope this helps.
 

·
ex owner/admin
Joined
·
10,839 Posts
Originally posted by njtech@Jan 1 2004, 09:21 PM
the plastic impeller has probably separated from the waterpump shaft. very common problem. don't drive the car, have it towed or you run the risk of damaging the engine. hope this helps.
another tech? cool do you work for BMW?
p.s-welcome to the forums
 

·
Registered
Joined
·
165 Posts
another tech? cool do you work for BMW?
p.s-welcome to the forums[/QUOTE]
I worked for an independant garage that specialized in German autos. I now have my own shop in NJ. Thanks for the welcome message, glad to be here.
 

·
ex owner/admin
Joined
·
10,839 Posts
Originally posted by njtech@Jan 4 2004, 08:37 PM
another tech? cool do you work for BMW?
p.s-welcome to the forums

I worked for an independant garage that specialized in German autos. I now have my own shop in NJ. Thanks for the welcome message, glad to be here.
[/quote]
thats great, welcome again, im sure youll be very informative
 
1 - 6 of 6 Posts
Top