BMW Werkz banner
1 - 8 of 8 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I made my 3 1/2 trip yesterday to pick up my first bimmer! Found out it has quite a few "little things" that need help. I was a technician at GM dealerships for 5 years, so hopefully it wont be any major thing. Interior is worn, but the car seems to drive smoothly. PLUS it has M3 wheels!

Bad phone pic, will take actual pics in a day or two!
 

Attachments

· Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
What did I get into?

Uh oh. In my haste to get a BMW, and that I picked it up at night, I may have gotten into more than I wanted. A few of the things I noticed last night/ today. No high beams. Like literally NO high beams, the bulbs are missing??
Glove box doesn't open. The inside latch part seems intact, it looks like it's in the handle part.
Hood latch lever won't latch down. It sticks through the grill all the time. Ambient air temp sensor doesn't work (either missing or unplugged is my guess as it reads -40.)
Sunroof shade is jacked up, cant really explain, it's definitely not in its track, but I don't know what else might be wrong with it.
The unlock and trunk open buttons work on the remote, but not the lock. I tried to reprogramming procedure (insert key and turn on and off, press and hold unlock while pressing lock 3 times etc.) and the lock doesn't work.
All doors lock with the inside button and automatically at speed, but the passenger side door lock "knob" doesn't go down.
Also, the passenger front window regulator is noisy.
Drivers rear "C" pillar panel looks like water leaked there. Possible sunroof drain?

Mechanically, the car seems sound. Ice cold A/C (we'll see how long that lasts :rolleyes: ), smooth shifting transmission, car is very smooth at 75-80mph.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top