BMW Werkz banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
i have a 95 325i and i just did the oil change today i was told to put 6.9 quarts of 10-40 in it, and it was smoking alot from under the hood and the exhaust so i put a new o2 sensor in it and it still smokes after i drive it hard. I can tell the engine is not performing at its full potential cause im haveing trouble keeping up with civics! its got a dinan cold air intake and im just not sure what it could possibly be. Can some one please help me out!!! Thank You
 

·
Registered
Joined
·
849 Posts
my first thought was that you spilled oil on the block or the headers...

but if you lost power?? did you change the oil filter??
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
yes i did change the oil filter and did spill a little bit of oil, however i lost power before the oil change and it was smoking before the oil change also. also i discovered today a burning smell comming from my front left wheel and there is grooves in the rotor so maybe its time for some new breaks.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
ok so i did have a seized caliper and i fixed it but the engine is still smoking after it warms up i read somewhere that it could be the valve cover gasket leaking in the back of the engine and the oil is dripin on the pipes causeing it to smoke is that correct? And yes i still have no power feels like the engine is accelerating but the car is not. its wierd really need some help thanks for the posts guys! keepem comming
 
1 - 5 of 5 Posts
Top