BMW Werkz banner

1 - 17 of 17 Posts

·
Registered
Joined
·
3,077 Posts
Discussion Starter #1
It is so miserable to drive around in my car lately, something is wrong with the AC. It doesn't blow hard enough to keep the car cold at all. Does anyone have any sugeestions. It has always been like this but lately the temp has been up 15 degrees so it sucks.

Thanks in advance.
 

·
Registered
Joined
·
2,276 Posts
is the temperature gauge in the car off? maybe the car is overheating or something. or maybe the car is on circulate and it's not circulating correct.
 

·
Registered
Joined
·
178 Posts
BMW A/C sucks in general.

When was the last time you had your A/C system checked out?
 

·
Registered
Joined
·
2,326 Posts
Get your AC system Charged. That's probably all you need.
 

·
Registered
Joined
·
3,077 Posts
Discussion Starter #5
How much???? I have a warranty with the car, will I need to use it? Because the warranty has a $100 deductible.
 

·
Registered
Joined
·
178 Posts
Originally posted by cam540@Jul 23 2003, 09:49 PM
How much???? I have a warranty with the car, will I need to use it? Because the warranty has a $100 deductible.
Couldn't tell ya, as I dont really know what is specifically wrong with your car... :dunno
 

·
Registered
Joined
·
2,238 Posts
Originally posted by cam540@Jul 23 2003, 06:49 PM
How much???? I have a warranty with the car, will I need to use it? Because the warranty has a $100 deductible.
recharging yourself will definitely cost less than $100.

http://www.bmw-forums.com/forum/index.php?...&st=0#entry8709

when you say "it doesn't blow hard enough," do you mean that the temperature of the air is warm? or the air is cold, but it isn't pushing a sufficient volume of it?
 

·
Registered
Joined
·
3,077 Posts
Discussion Starter #8
The air is cold but when I turn the AC on full blast it only blows at the lowest speed.
 

·
ex owner/admin
Joined
·
10,839 Posts
im incline to agree with Bob, i think maybe you need a freeon recharge or your compressor is starting to go.
 

·
Registered
Joined
·
2,238 Posts
Originally posted by cam540@Jul 23 2003, 09:53 PM
The air is cold but when I turn the AC on full blast it only blows at the lowest speed.
ah, ok that is good info.

if it is cold, your compressor is fine, and you don't necessarily need a recharge, although that never hurts.

no air movement = fan is dying or microfilter is completely plugged.

when i get home i can look up the symptoms for you in the TIS. in the meantime, check the fusebox. there is a diagram inside the fusebox cover, and there are about 4 or 5 fuses associated with various components of the a/c, i can't remember offhand if one of them is the cabin fan.

microfilter is easy diy. but i've never worked on fan before, so i can't tell you how hard it would be. but i would bet that labor alone would exceed the $100 deductible, so it may be worth it to put it on the warranty (after you rule out microfilter).
 

·
Registered
Joined
·
3,077 Posts
Discussion Starter #13
perfect des, thanks!! Looks like I need to order the part and get ready to fix this!!
 

·
Registered
Joined
·
497 Posts
------>>>> REPLACE YOUR FIANL STAGE RESISTOR!! do you have an E46 or E36 ? Lemme know if you need help
 

·
Registered
Joined
·
497 Posts
harder to replace than E46, but still not that bad
Let us know what happens Cam .
 

·
Registered
Joined
·
1,192 Posts
My AC works 100% but I don't use it... EVER cause im scared it will break
 
1 - 17 of 17 Posts
Top