BMW Werkz banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My son bought a 318i. Its my first BMW as well. It has about 130k miles and seems to run ok. I dont think it was serviced well by its previous owner. The crankcase oil stank like I have never smelled oil before. Anyway, I tell you that because my son was driving from work about 55 mph and it lost power. He said it acted like it ran out of gas. It still had about a 1/4 of a tank, which he verified by filling it up with 10 gals. When he got off the highway, the car seemed to find whatever was lacking and ran good again.

Where should I start with this? I have a fuel filter for it, should I go directly to that or should I look at something else. I just put plugs, wires, rotor and cap on it and it still just barely passed emissions testing in GA. We had to replace the CAT and that got us into passing, but just barely.

thanks in advance

steve :cry
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Hey thanks....the fuel filter is no problem....what relays are you talking about? I have a Haynes manual that I have been looking at...are you talking about Throttle Position Sensor or something in the fuel pump area? steve :c
 

·
Registered
Joined
·
165 Posts
Originally posted by Slider@Feb 7 2004, 10:05 AM
Hey thanks....the fuel filter is no problem....what relays are you talking about? I have a Haynes manual that I have been looking at...are you talking about Throttle Position Sensor or something in the fuel pump area? steve :c
when you open the hood, on the driver's side next to the fuse box there are relays. just make sure they are making good contact.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I think the fuel filter was the problem...at least it really needed changing as it had a lot of dirt drain out of the bottom of it when the hose was pulled off. Also, it was very hard to blow through it when I had it completely off the car as compared to the new one, which was way easy. Some of the resistance I guess could be froma wet element. I am thinking of hack sawing the filter apart to see just how much dirt is there...thanks for your suggestion....I will also check the relays.
 
1 - 5 of 5 Posts
Top