BMW Werkz banner

1 - 7 of 7 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
hey all
out of the blues, when driving, the left-turn indicator light was not blinking-completely dead. (i cant remember what its called hehehe... :confused ) anyways so yeah the ligths outside are blinking normally, the clickin-like-metronmoe sound is still going, but the left sign isnt working. Even when i activate "Flashers", only the right "arrow" works, or if i give a right sign.. but the left arrow on the dashboard is dead.. any advice ? is it a fuse or a led in the board ? how to fix it ?
 

·
Registered
Joined
·
698 Posts
I would say a bulb. Pull out the cluster and look for a bulb near the indicator.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #4
Guyz i think i wasnt explaining enough am sorry: the right flasher is working fine, the problem is only on the dashboard.
Tnx anyways andrew.
 

·
Registered
Joined
·
391 Posts
There is a bulb on the back side of the instrument cluster behind the turn indicator. This is a mini light bulb, not an LED. You will most likely need to pull the instrument cluster out to replace the bulb. The right indicator will light and work correctly if the left bulb is burned out.
Ben
 

·
Registered
Joined
·
242 Posts
That's what Andre saying pull your cluster gage out check your bulb mine went out on the right side didn't bother two years later the whole cluster died. :wtf :cya
 

·
Registered
Joined
·
48 Posts
Discussion Starter #7
i dunno what happened.. the left indicator is working again.. but i noticed that my airbag light came on again after fixing it 2 times.. i have this feeling its the cluster.. this might not be a coincidence...
 
1 - 7 of 7 Posts
Top