BMW Werkz banner

1 - 20 of 21 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
:cry My roomate thought he'd give me a hand and hooked up jumpers backwards.. Now when I try to jump it nothing, I mean nothing happens, no dash lights, no nothing.. I am very handy with this thing but I checked fuses, connections, etc... and I cannot get anything to happen!!! Can anyone help??!!!
 

·
Registered
Joined
·
5,253 Posts
i wouldnt doubt that ur electronics are gone now. i dont really have anything to say becuase i never heard of someone doing that. hope everything is ok
 

·
Registered
Joined
·
191 Posts
maybe you need to charge your battery, that happens to me all the time. I havent figured out whats wrong with my car though, cuz the battery's only a year old.
 

·
Registered
Joined
·
5,253 Posts
Originally posted by bimmergurl10@Aug 27 2003, 11:57 AM
maybe you need to charge your battery, that happens to me all the time. I havent figured out whats wrong with my car though, cuz the battery's only a year old.
u hook up your battery up wrong alot like his friend did?
 

·
Registered
Joined
·
2,326 Posts
You blew your alternator. Get it changed. Beat your friend for being a dumbass.

bimmergurl10 - same same, change the alternator. It's not the battery that's gone, the battery just aitn charging correctly because the alternator is shot. Do you have a bumping system in your bimmer?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
So you think it is alternator eh?? 87 325i... No bommin system.. yet, needs to run first now!! I am about to have clutch put in when this happened also, just what I need now.. blown alternator.. Are you sure that's it?? You've seen this happen before??

The stink of this whole thing is, I did not tell him to touch anything!!!!!
 

Attachments

·
Registered
Joined
·
2,326 Posts
1) Welcome to the board, I done forgot to welcome you :welcome
2) I haven't seen this before, but if you cross the pos and neg on the jump the first thing to go (baring the battery exploding) is going to be your alternator :nono. Unless of course the red was on the neg on his battery and on the neg on your battery, then it wouldn't matter.
3) You could remove the alternator and take it to a shop to be tested, they will tell you for sure if it's blown
4) You could purchase a enw battery and replace yours. If it works then it wasn't the alternator. If it doesn't, return the battery and replace teh alternator.
5) There is also a chance that it's a blow relay and not the alternator, battery, or any fuses. :idea2
 

·
Registered
Joined
·
2,053 Posts
:welcome

i'd go with greendragons advice, you couldve also screwed up some other stuff by doing that such as your abs or other electrical stuff.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #9
Thanks for the welcome aboard! I should have done this a long time ago...

Any Idea which relay would blow if alternator is not bad??
 

Attachments

·
Registered
Joined
·
2,326 Posts
I haven't the slightest clue what relay it would be, sorry. I don't really know much about the e30 models. You may be able to find a wiring diagram (or something of that sort) on the interweb that may help you out though.

Good luck!
 

·
Registered
Joined
·
191 Posts
well i found my problem with why my battery kept going dead. My stupid glove box light was staying on, even when it was closed so i disconnected it and hasn't happened since..and i hope it stays that way :blink: . And no i didnt hook my battery up wrong. I may be dumb, but i'm not THAT dumb. I know what i'm doing lol :D
 

·
Registered
Joined
·
14 Posts
Discussion Starter #12
Well fella's, All fixed... NOTHING BURNED OUT EITHER.. I removed alternator and had it tested.. Was fine, as a matter of fact, the alternator does not complete the circut. Either way, after that, I went and saw the guy who is doing my clutch for me, he pointed me towards a fusible link in the trunk, hard to find if you dont know it's there... It was fine though, so I started tugging on some wires coming out of the fuse box trying to trace them, and then boom! My wipers kicked on, I had continuity.. Turns out that there is a little junction box on pass side firewall where the positive battery terminates and distributes power.. The shock must have shaken it loose.. Problem solved!!!! Did not even cook my radio... Thanks again for all of your suggestions. We all learned something!! (don't let anyone else touch your car!!!)
 

Attachments

·
Registered
Joined
·
2,326 Posts
Rock on! Glad to hear you didn't fry anything. Did you secure that junction box so it won't losen up again, just in case?
 

·
Registered
Joined
·
4,663 Posts
sweet dude.
 

·
Registered
Joined
·
5,253 Posts
whoa. that is werid :idea2
 

·
Registered
Joined
·
14 Posts
Discussion Starter #16
very odd, indeed... Hey, check out my old 320i.. Had lunch with a rock on the side of the road!!! Even with lowering springs it is definately not a "handler"
 

Attachments

·
Registered
Joined
·
5,253 Posts
Originally posted by JUSTIN_325I@Aug 28 2003, 02:11 PM
very odd, indeed... Hey, check out my old 320i.. Had lunch with a rock on the side of the road!!! Even with lowering springs it is definately not a "handler"
must of been a big rock :confused
 

·
Registered
Joined
·
4,663 Posts
dang that sucks
 

·
Registered
Joined
·
14 Posts
Discussion Starter #19
It was a blessing in disguise.. Car was not cutting it anyway.. Severly undergunned!!! I sold it for $200.00 and this is what the guy did with it, pretty nice eh?? He had the time and facilities to fix it.. Two things I did not have...
 

Attachments

1 - 20 of 21 Posts
Top