BMW Werkz banner
1 - 16 of 16 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
I am wondering how long it normaly takes for the heating system to get hot in my car....

The front screen heat is hot as soon as it gets to the half way mark but if i change the setting to the face it is stone cold and the only way i can get anything is if i am pushing the car hard. Even if i put it to my feet its still hot its just this setting...

I have had it hot but it took over 30 mins.....

I have checked for ait bubbles and there is nothing also changed viscus fan see if that might have been problem (It needed changing anyway)

I am not losing any water as far as i can see also so not sure what it could be......
 

·
Premium Member
Joined
·
14,730 Posts
Maybe there's an issue with the ducting and flaps that guide air to the upper vents through the heater core.
 

·
Registered
Joined
·
570 Posts
Do you have a nob in the center vents with blue/red dots on it? If so turn it to the red dots and you will get heat on your face.
 

·
Help from over the pond
Joined
·
3,239 Posts
+2, Ive heard of this so many times.....
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #6 ·
No disrespect but i keep my heat on red all the time ;-) basicly saying i'm not an idiot lol.... also where do the ducts come from witeshark?
 

·
Premium Member
Joined
·
14,730 Posts
How does the controller that switches between defrost and bottom/upper vents seem to act? My thought is that only the defrost and bottom vents are directing air through the heater core.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #8 ·
well as you know the E36 has 3 knobs..1st is air supply 2nd temp 3rd air distribution..

I always have my fan on 2 its always on hot and air is normaly on windscreen.. As i said if i put it directly on upper body its just cold and takes around 30-40 mins to even feel any warm air unless i am ramping the car..... all my vent are working fine i just get cold air from the upper body part.. the screen and feet are working normaly.

Also where is the heater core? i got 2 days off work so maybe i can try and clean it or something.
 

·
Registered
Joined
·
54 Posts
I have the same problem. On my defrost and lower level vents my heater works fine. But when i switch to the face or mid vents it blows cold. It is the flapper. I have a 2 door so defrost is just enough heat for me. Good luck tearing it apart and let me know how it goes. The heater core should be a FUN job.
 

·
Premium Member
Joined
·
14,730 Posts
The heater core is a mini radiator just like the engine cooling one. It's typically mounted inside the firewall in the dash assembly.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #16 ·
Ok looks like i will have to stick to keeping it between my face and feet setting then as thats the only way i can get a little amount of heat....... As i said earlier another job for my mechanic :-(

Cheers for your help anyway all :)
 
1 - 16 of 16 Posts
Top