BMW Werkz banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,751 Posts
Discussion Starter #1
Actually this topic has always pissed me off since I've owned my bimmer 4 months ago.. I bought it with an aftermarket Pioneer CD player, no cd changer in the trunk, and the woofers in the front kick panels were some Orange colored DELFI speakers as well as the ones in the back..... Well it's always sounded soo terrible that It makes me think they are not original speakers and he had a full system in there before he sold the car as the RCA cables are still under the carpets...... I'm just wondering if your stock systems have decent bass for STOCK, and if you've ever seen your kick panel woofers, what color are they? thanks
 

·
Registered
Joined
·
2,294 Posts
if there are rca cables he had a system
 

·
Registered
Joined
·
263 Posts
anything other then stock sounds better. amp and subs wired by monster cable wires sound GREAT.
 

·
Registered
Joined
·
2,907 Posts
Mine has the old cruddy amplifier sound combined with a bad midwoofer sort of sound. Right now it's totally stock with cd changer in the back. It's not that bad but there is no deep bass, and midbass sounds quite distorted and muddy.
I have almost everything I need to replace my entire audio system, I'm only waiting on a specific amplifier to appear on ebay (Cadence A4) to match my A7.
Since I’m new here and I like the place, I'll probably be a repeat visitor here. So I'll photo journal the install process and provide some recordings of before and after.
I'm replacing everything except the stock wiring harness from the head unit to the amp.

Changer, stock amp, and head unit are all being replaced.
A 2 cubic foot custom built 15" subwoofer with a Cadence A7 (1400W) amp will be added.
Only thing I'm not replacing in the near future are the speakers. I've read in other forums where some say their speakers are nice, and some people say their speakers are horrid. Once I get all of the electronic replacements done, I'll work on the speakers.
I was going to go up to the steel shop yesterday to put the enclosure together since it was too cold last time I was there... But my car's engine light came on and its being sluggish so I don’t feel comfortable driving it. I guess I gotta wait till next weekend.
 
1 - 5 of 5 Posts
Top