BMW Werkz banner
1 - 9 of 9 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
COMPUTER MALFUNCTION PROBLEMS OCCURRING AGAIN. LAST WEEK I HAD AN EMMISSIONS RELATED FAULT MESSAGE AND THE CHECK ENGINE LIGHT CAME ON, THE NEXT DAY WHILE DRIVING TO WORK ALL MY LIGHTS ABS, STC, CAME ON ALONG WITH "TRANSMISSION IN FAILSAFE MODE" MESSAGE PULLED OVER SHUT DOWN, RE-STARTED ALL THE FAULTS WERE GONE EVEN THE CHECK ENGINE LIGHT!!
SO YESTERDAY i START THE CAR AGAIN EARLY IN THE MORNING AND GET ALL THE ERROR MESSAGES AGAIN, TRNS FAILSAFE MODE, THEN ALL THE BACK LIGHTS ON THE DASH AND NAVIGATION GO OUT, THE LAST MESSAGE I SEE BEFORE SHUTING DOWN IS "GENERATOR FAULT". I LEAVE THE CAR PARKED, COME BACK IN THE AFTERNOON SHE STARTS RIGHT UP, WITH THE ENGINE LIGHT ON AGAIN AND "EMMISSIONS RELATED FAULT" MESSAGE IS BACK ON. I DRIVE HER SOME 10 MILES SHUT DOWN WHEN i START HER BACK UP AGAIN NO FAULT MESSAGE, NO ENGINE LIGHT ON, ALL SYSTEMS O.K WTF!

WAS FINALLY ABLE TO GET INTO THE "SECRET" MENU AND GOT THESE 4 CODES listed under #14 "fault memory"
0A3B2 20 000 3E1B 79
1931D 22 000 3E6E 45
2A3AA 20 000 3E6E 65
8E111 20 031 3A94 7C

I THINK THE FIRST TWO ARE OLD CODES BECAUSE WHEN i BOUGHT THE CAR i HAD TO TAKE IT BACK AND THEY REPLACED TWO ENGINE COILS AND PROBABLY DIRENT CLEAR THE MEMORY.

CAN ANYBODY HELP ME DEFINE THESE? HOPEFULLY IS SOMETHING EASY TO FIX
2004 745I 82,000K MILES
 

·
Help from over the pond
Joined
·
3,239 Posts
Unfortunately I cant help you on this as they are fault codes for the BMW diagnostics set up GT1 and probably their newest one which not to many people know about, which is very expensive to buy and not many people have, if you have a Peake code reader that would give codes that can be read and worked out..
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
I did use a reader as well but it only defined the second code these are the codes i got:
p1891
p0139 - this code it said it was "02 sensor ckt slow responce (bank1/sensor 2)"
p1058
p1055
but the other codes were not listed in the book
 

·
Help from over the pond
Joined
·
3,239 Posts
Ok, Im 99.9% positive your battery is failing or your alternator is not pushing out the voltage, as its only done 82k I would say go get yourself a new battery as the alt should be fine( but you never know) BM alts normally go well beyond 150k sometimes 200k plus, do go get one from BMW and not a cheapo, let me know if Im correct as Im so certain I am....

Note:If you only do stop/start journeys the batt will die within 2 yrs, these cars are motorway/highway cruisers and not around town cars and need distance to maintain the electrical system the main one being the battery, also remember the power taken to start a 7 takes 1 & 1/2 hours driving to put back in to the battery...
 

·
Help from over the pond
Joined
·
3,239 Posts
No problem, can I just say one thing if possible when posting can you use 'lower case' apart from capital letters its so much easier to read...
 

·
Registered
Joined
·
1,494 Posts
P1891 = System Voltage High Input
P0139 = O2 Circuit Slow Response(Bank1 Sensor2)
P1058 = VVT - Voltage Supply Control Motor, Low Input(Bank2)
P1055 = VVT - Voltage Supply Cointrol Motor, High Input(Bank1)

I'd follow marti's advise and check alternator and battery... and i think that will take care of P1891, P1058, and P1055.

for P0139, replacement of the O2 sensor is the only remedy.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
battery and alternator voltage

o.k i'm getting 12.35 volts from battery with the car off, and 14.20 volts from the battery with the engine on (radio playing etc). its weird because it only seems to happen every couple of days and early in the morning (this past Saturday was last time). When i tried to start got all the yellow light abs,atc etc. but the car started, and the backlight on the dash went dark. I just turned it off, removed key and it started again normal with no warning lights, just the "emissions related fault" message whitch cleared after the next restart.
Could this be a power modual or control unit?
I really don't want to spend all kinds of money on a new battery if thats not the case, last few days I've been checking the battery voltage and its always 12.2 +volts
Any suggestion? testing techniches?:werd:
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top