BMW Werkz banner
1 - 10 of 10 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
recently acquired my first bimmer for $1300,(1987 325e 6cyl) overall in good shape, 182k. i've put in a new fuel filter, last owner just did platinum plugs. When i start the car and say hold the rev at 3000 rpm it will drop to 2700 and go back up and repeat, same flux happens at idle speed. Any ideas? also, manual crank sunroof is incomplete but rails spin, the black clips move up and down the rails but are broken on one side and missing on the other. I want to put a salvage roof in, do you have to remove headliner to remove the tracks that go into the roof of the car. any feed back helps thanks, jeff
 

· Registered
Joined
·
1,493 Posts
recently acquired my first bimmer for $1300,(1987 325e 6cyl) overall in good shape, 182k. i've put in a new fuel filter, last owner just did platinum plugs. When i start the car and say hold the rev at 3000 rpm it will drop to 2700 and go back up and repeat, same flux happens at idle speed. Any ideas? also, manual crank sunroof is incomplete but rails spin, the black clips move up and down the rails but are broken on one side and missing on the other. I want to put a salvage roof in, do you have to remove headliner to remove the tracks that go into the roof of the car. any feed back helps thanks, jeff
1) platinum plugs DO NOT work well for this bimmer series. Whe you can i suggest you revert back to the factory specified copper core plugs.

2) what about air filter? clean?

3) there's no reason for u to rev your engine at 3000rpm when stationary for extended periods of time, and there is a rev limiter circuit in place that will keep ur engine from overshooting it's limits, depending on how your engine sensors feed info to the injection brain(DME/ECU).

** in place of stationary revving... do the driveability test instead. take the car out for a drive and run it to 3000rpm in gear(load). if it pulls cleanly. you are OK! ;)

erratic idle (say +/- 750rpm) - now that's a different issue. if the idle is unstable, your frst line of suspect will be dirty ICV, MAF meter, and throttle body. Clean those parts first with carb cleaner and re-test before thinking that parts are faulty.

:)
 

· Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
thanks, actually i may have been over reacting and it just might have been a little cold this morning seems to be idling fine now just sometimes i feel a short lag while i'm driving..... will keep stock plugs in mind thanks guys
 

· Registered
Joined
·
650 Posts
The cold does play a big part in the issue. I don't see why everyone has problems with there plugs, I've got iridium platy 4's and they havn't caused me any trouble.
 

· Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
ya im not so sure why such plug drama either..... i'm not a rocket scientist but it seems as plugs serve the same function if gapped right, and a better plug seems like it yield better results
 

· Premium Member
Joined
·
364 Posts
ya im not so sure why such plug drama either..... i'm not a rocket scientist but it seems as plugs serve the same function if gapped right, and a better plug seems like it yield better results
I thought the same thing until i got my Volvo 850. The car hated the 15 dollar a plug indiums that it came with. Swapped them out for the 1.50 copper plugs and she has been happy since.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top