BMW Werkz banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys I've got a problem and can't figure it out. I've got a 1990 325is, and something's wrong with my heater switch. It only blows air if I put it on "4", no air if I put it in position 0-3. Another thing, sometimes when I start the car it doesn't even blow any air on 4 either, but later I'd be driving, and it would start blowing air out of the blue. I've checked the fuses, they're all fine. But as I take it its definitely not a fuse problem. Maybe a relay?:wrench :wrench :wrench

Any ideas?
 

·
Help from over the pond
Joined
·
3,239 Posts
probably the switch is worn out.....
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
That's what I thought at first, so I actually changed the whole a/c, heat switch panel. The new one I put it worked perfectly fine on the car I took it off from. But I still have the same problem, that's what making me think it might be a bad relay. Is there any way to check that?
 

·
Premium Member
Joined
·
14,730 Posts
It may be the blower fan resistor. That would explain it working only on 4 which is full on and not using the resistor.
 

·
Registered
Joined
·
1,494 Posts
^^ +1

witeshark is right. it is the blower resistor!...

when that guy goes bad, it defaults into the "4" position with all other positions dead.
 

·
Registered
Joined
·
1 Posts
new member

Hi-I have the exact same car, 1990 325is Black, as maxa2j and with the exact same problem. Blower only works on 4, and I guess it's the resistor. Where is it located? Thanks PS: I also a Pelican member (86 911)
 

·
Registered
Joined
·
2 Posts
Hi, Ive only just joined this board and was looking to solve the same problem - blower motor only works on position 4. I cant see anyone answering how you might be able to solve it yourself but I found this link elsewhere on the web - includes pictures of what to do. Hope it helps. I will try it and see if it works this week!

Cheers

Raymondo
 
1 - 8 of 8 Posts
Top