BMW Werkz banner

1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I recently bought this car and its great except no heat from the center vents. The defrostand foot vents are hot. But the center vents are always cold even when I adjust the little dial in the middle of the dash. It would be nice to have heat for me hands 2!!! Any ideas?????
 

·
Registered
Joined
·
209 Posts
In my 85 528e i have some major heat issues. When the fan is running for the heat, it squeakes like crazy and vibrates the whole car. Then sometimes it wont turn on at all, but when i hit A/C button the fan starts turning, when i turn off A/C the fan stops turning. Also if the fan isnt turing for the heat, when i start from a complete stop, it starts turning again, unless i turn it off and try to turn it back on again, then it stops and wont turn back on. I need some help.
 

·
Registered
Joined
·
26 Posts
fan may need to be tightenend ... check for lose belts ... possible bad connection somewhere ....
 

·
Registered
Joined
·
209 Posts
When i accelerate really hard, the heat will suddenly turn on, but it makes a god aweful grinding/squeaking noise where my windshield meets the dash. The fan under the radio does not squeak. Is there a seperate fan in the dash that i do not know of?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
No, I really ahven't even looked at it yet since I have pleanty of heat for the defrost and floor. Will get back to you after I investingate.

MH
 

·
Registered
Joined
·
1,645 Posts
I heard others complaining of this same problem. You said you've tried turning the wheel in the center of the vents to hot and that didn't work. When you turn that wheel, does it feel like it is connected on the other side? I'm wondering if it is disconnected from the part it moves on the other side of the wheel?
 

·
Registered
Joined
·
1,645 Posts
I'll merge with the other heater question thread.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
The center wheel does not feel like it's connected to anything. I figured it was just a veriable resistor and did not expect any feel or feedback from the dial. I will check the dial tonight.

Thanx!
 

·
Registered
Joined
·
82 Posts
Originally posted by mahill69@Dec 5 2003, 07:45 AM
I recently bought this car and its great except no heat from the center vents. The defrostand foot vents are hot. But the center vents are always cold even when I adjust the little dial in the middle of the dash. It would be nice to have heat for me hands 2!!! Any ideas?????
The center vents are not supposed to put out heat. That is the way the HVAc system is designed in the E28 models.
 

·
Registered
Joined
·
82 Posts
Originally posted by Old528e@Dec 14 2003, 03:49 PM
In my 85 528e i have some major heat issues. When the fan is running for the heat, it squeakes like crazy and vibrates the whole car. Then sometimes it wont turn on at all, but when i hit A/C button the fan starts turning, when i turn off A/C the fan stops turning. Also if the fan isnt turing for the heat, when i start from a complete stop, it starts turning again, unless i turn it off and try to turn it back on again, then it stops and wont turn back on. I need some help.
The earlier E28 utilizes 2 fans. One for the a/c and one for the heater. IIRC the 87&88 models have only one fan for both. These fans are located above the ashtray in the center console. The problem with the squeeking is caused by a bad bearing. Your intermittent problem is either a bad ground or loose connection.
 

·
Registered
Joined
·
209 Posts
How would i go about reparing this problem. And are both fans above the ash tray under the radio? or is there another one somewhere else in the car. Cause i know i can see one of them, but i dont see two. And refering to the bad bearing, how would i go about fixing that?
 

·
Registered
Joined
·
82 Posts
Both are in the console above the ashtray. They are side by side, that's why you think you see one. If you turn the a/c on, the "squirrel cage" on the drivers side will spin, and if you turn the heater blower on the "squirrel cage" on the passenger side will spin.
As for the bad bearing you will have to replace the motor. If you don't want to and can't take the squeeking maybe some lithium grease will help. DO NOT use WD40.
 
1 - 13 of 13 Posts
Top