BMW Werkz banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 95 325ic. Intermittently, I the flashers come on when I start the car. They remain flashing until I turn them off by pushing the flasher button on the console. This may happen for two or three starts and then doesn't for two or three starts. Any idea how to fix this?
 

·
Registered
Joined
·
2,421 Posts
I'll hit up our ex-bmw mechanic for you as I see you are threading this question on other boards also and I want to see if we can help you out..
 

·
ex owner/admin
Joined
·
10,839 Posts
well i have to ask the obvious. are you sure you dont accidently hit the button when your leaving your car?

now with that out of the way. do you have a keyless entry? or some sort of aftermarket alarm that triggers the hazards to notify of an arming of some sort? if so try locking without the remote (use just the key) for a while and see if it still happens.
 

·
Registered
Joined
·
497 Posts
whoa, that's an odd one. they just keep getting more weird every time. I've never heard of such a thing. I would have to ask the same as Furious: does the car have an aftermarket alarm system or keyless entry? But then I think, why would you be able to turn the flashers off with the switch on the console if they weren't turned on by the switch on the console. Has there been any kind of major work done on the car? Any major repairs, electrical or body. Are you sure you're not accidentally hitting the button with your elbow or something? Try starting the car with your left hand and see if they come on then.
 

·
Registered
Joined
·
2,326 Posts
Question - if he was hitting the button wouldn't the flashers continue to flash even without the key in the ignition? If so, wouldn't it be very obvious if he had?

After market alarm going wacky is where I'm leaning.
 

·
ex owner/admin
Joined
·
10,839 Posts
ya they should keep flashing but who knows it could be him hitting it when hes starting the car. however maybe the button is partially stuck or something . any coffee or pop spilt on the button that you know of? or better yet do you have the cup holders (like i do) that are close to the hazard button?
 

·
Registered
Joined
·
1,491 Posts
im betting its the alarm, the person that owned the car before me put in an aftermarket alarm and now the only way to unlock the car is by the wireless button. if i use any of the keys in the doors the alarm goes off...its pretty damn annoying. you think i can fix this?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Gentlemen,

Thanks for all the suggestions. The car does not have keyless entry or alarm. The flasher button is positioned in a place where it would be difficult to hit once, let alone as many times as this has happened. The cup holder comment has caused me to wonder. With kids driving the car, a spill is a distinct possiblility. I will look into that one.

Jim
 
1 - 8 of 8 Posts
Top