BMW Werkz banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi, first of all I want to say great site and great information. I've just joined and am needing some help.
When I accelerate the engine is pulsating/shuddering @55 mph/1500 rpm. When I just coast it is smooth. When it downshifts it smooths out also. Checked plugs, wires, changed fuel filter, etc. Any ideas?
Thanks.

BTW 325e, auto
 

·
Registered
Joined
·
16 Posts
Have you checked out the fuel pump? Sometimes the delivery rate from the pump to the injectors decreases, causing lowered pressure to the injectors. It might run fine at lower speeds but as the demand for fuel pressure increases, its just not available. Just a thought and it might be something worth looking into.
 

·
Registered
Joined
·
310 Posts
thats pretty bad, when was ure last service?
 

·
Registered
Joined
·
537 Posts
my car did the same thing when we first bought it, and the mechanic said it was somthing to do with the cruise control (don't ask me how). then he replaced the unit and that fixed the problem.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Well, I appreciate the help, will try those things. Also going to run diagnostics before anything as that will probably be smartest in not throwing away money on things that working correctly already
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I just had a car diagnostic done...$75
#5 injector is dead, that would acount for alot.
Also need valve adjustment. Defintely worth running a diag. test before doing any guess work.
 
1 - 6 of 6 Posts
Top