BMW Werkz banner
1 - 9 of 9 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hi guys,

I've searched the forums for this problem, but had no luck so i'm creating a new post. I've been driving a 1997 328is for the past year and a half. When I purchased it in the summer of 2008 the car was working fine. However, I noticed a few months later when the days were a little bit hotter that the car would run really hot when the car was idling a lot in traffic. It would also become very sluggish when it was hot and at times would pretty much have no acceleration from a dead stop. Then winter came and I noticed that the engine was running really cold, if the car was on inside roads and at low speeds, the problem was not so bad but when I drove on the highway, the temperature needle would be just above the blue marking on the gauge. I survived that winter and this past summer I had a few parts fixed in the car and my girlfriends dad who worked for BMW told me that the auxiliary fan was not working and it was due to a seized motor. So we replaced the motor and the fan started working great and the overheating problem went away, however, he used same clip holding the fan to the motor which came loose so I had took the fuse out to stop the motor from spinning. Her dad then used glue to glue the fan back on to the motor and when we put the fuse back the fan would not turn on. So now I'm stuck driving a car that runs really cold. I mean i'm freezing in there. Is this low temperature problem related to the auxiliary fan or could it be something else? Please help me!! Thanks in advance guys.
 

·
Administrator
Joined
·
593 Posts
Thermostat first, then heater control valve (the one that lets the coolant get into the heater core), then check the heater core itself to see if it is clogged. You can flush it out with a hose and water after disconnecting the hoses going to it to see if you have good flow.

Nadeem
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
Thanks for the input guys, I really appreciate it. The thing is I had the stat replaced around the end of 2008 and the problem still persists. I'm going to take a look at the heater control valve and the core and get back to you guys.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #5 ·
hey guys! so i haven't been able to take a look at the car since I've been busy with work. But I'm thinking now that maybe I should check out the thermostat first before I get into the other stuff, just in case it is a simple solution. I wanted to know, is there an easy way I can test out the thermostat to see if its working?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #8 ·
sorry to sound like an idiot, but what would I be looking for? I just wanna fix this problem as fast as I can. I'm freezing in the car, and I'm sure this isn't great for the engine either.
 

·
Premium Member
Joined
·
14,730 Posts
With water near but not at boiling, put the cool or cold thermostat in and see if anything moves.
 
1 - 9 of 9 Posts
Top