BMW Werkz banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 92 325 i. THe engine seems to be ok when i drive the car, but as soon as I stop it it stars to overheat. The gauge goes to the 3/4 line and the electric cooling fan switches on to bring it back back to normal. This is really pissing me off, because i changed my radiator, waterpump, and fan clutch like a month ago. Im raelly stuck with this cause nobody seems to know what the problem is. If anyone could help me with this, I would appreaciate it very much..

Thanxx
 

·
Registered
Joined
·
4,663 Posts
did you check for sticking thermostat?
 

·
Registered
Joined
·
4,708 Posts
Originally posted by BMW_325_i@Aug 24 2003, 09:54 PM
I have a 92 325 i. THe engine seems to be ok when i drive the car, but as soon as I stop it it stars to overheat. The gauge goes to the 3/4 line and the electric cooling fan switches on to bring it back back to normal. This is really pissing me off, because i changed my radiator, waterpump, and fan clutch like a month ago. Im raelly stuck with this cause nobody seems to know what the problem is. If anyone could help me with this, I would appreaciate it very much..

Thanxx
check the thermostat...
 

·
Registered
Joined
·
497 Posts
who replaced those parts? Was the system properly bled after the replacement was done? Have you checked the coolant level again? Check that, because it's easiest. Then I would suspect the thermostat.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
i just replaced my thermostat but that does not seem to be the problem. All of the parts were installed by a proffesional auto mechanic. Also the system was bled properly. I really dont know what to do anymore about this. I changed almost the entire cooling system, still engine overheats. Is this supposed to be like this?? Could this be normal with this model???
 

·
ex owner/admin
Joined
·
10,839 Posts
Originally posted by BMW_325_i@Aug 25 2003, 08:29 PM
i just replaced my thermostat but that does not seem to be the problem. All of the parts were installed by a proffesional auto mechanic. Also the system was bled properly. I really dont know what to do anymore about this. I changed almost the entire cooling system, still engine overheats. Is this supposed to be like this?? Could this be normal with this model???
any leaks? any suspected leaks? check the undercarridge for a greyish looking-cooked on substance. if you have some i suggest checking your hoses, waterpump, and thermostat housing. lastly what temp are you running on a more consistant basis? normal or 3/4? maybe check to make sure there isnt an electrical problem.
 

·
Registered
Joined
·
3,240 Posts
make sure they got all the air ount of the system, when i had my radiator changed they didnt bleed it properly and it did the same thing.....
 
1 - 8 of 8 Posts
Top