BMW Werkz banner

61 - 80 of 83 Posts

·
quality
Joined
·
7,256 Posts
Alex MPower said:
Ok....
As read all of the above some of you have a lot of problems!
So,my cusine 4 month ago bought a 2006 530, i love thet car! And you know what since he bought it he have never had any problems!!! I drove it meny times and i love it!!!
Some answers:
About steering wheel: at low speed it have a low rate,at high speed the rate is higher,and some times when you go from low to high speed very fast,on the corners the computer doesn't have enouth time to change from low to high and back,it takes some time to change it! And i realy think it depends on car and on driver. !
interesting...I wonder why they do that :confused:
 

·
Registered
Joined
·
1,800 Posts
Discussion Starter #62
I started this thread in 6/04. It's now 3/08, almost 4 years later and 4 years, 3 months since I purchased my 2004 530i. I thought I would report in on the current status of my ride.

I took the car in just before the warranty ran out and got them to replace all the brakes/drums...It had just a minor squeal.

The right rear tire has had a slow leak since the car was brand new. I finally got them to keep the car over night and test the wheel in a water barrel. The tech found no leak and no problems with the tire. I went in the next morning and I had the tech take the air pressure in front of me---sure enough---it was down 1.5 lbs. The tire and the rim were replaced.

I also had them replace the front windshield rubber molding...it had some areas that were coming apart and had small tears.

I had them detail the car. The scuffed up my 3m clear bra that I have on the hood.
Idiots. I mean, it still works and everything..it's not torn. I just don't have time to follow through on a complaint. (Shelly BMW-Buena Park, CA)

Everything else has been working fine. Have only 21k miles on it, though. Not much so the jury is still out on this car. It still looks brand new, in and out.

We drove Hwy 101 from Santa Cruz (near San Francisco) to Los Angeles and the car was outstanding. Handled great, especially at high speed (up to 120mph), averaged about 80mph. Got 24 mpg, xlnt acceleration. Great sound system. A bit of wind noise at speed.
Sport seat were okay in comfort, a little stiff. We stopped along the way a couple of times to stretch our legs. The sport suspension was like traveling on rails and is pretty stiff as well. If you want to tour with the new BMW's, get the standard suspension.

With the problems sorted out, it's been a fun driver but it took too much effort to get them straightened out, though.

Bottom line, don't buy a first model year car, especially one filled with electronics.
 

·
Registered
Joined
·
1,800 Posts
Discussion Starter #63 (Edited)
By the way, with all the negative press about the idrive, once you have it set, it's not that big of deal. It takes a bit of studying to get all the details, but imho, it's better than have a ton of buttons with icons that you might not remember.

I'm the designated home electronics tech in my family and spent years in IT, so I'm def. biased.

One thing I did spend a bit of time on was adjusting the sound system e.q. As a musician and sound guy, my ear is tuned to finding fault with any system.

It took awhile but what I came up with is to set the EQ with (from left to right, from memory) 6 bars, 2 bars, 2 bars, 4 bars, 6 bars, 8 bars, 10 bars), stair step it up like that.

Then with the treble/bass controls, I dial in how much overall treble/bass I like, sometimes depending on what song is playing because all the 60's- 70's tunes were all mixed differently. The E.Q. can be fine tuned to your liking but the main thing I did was really knock down the mid-bass because the subs are too small and those frequencies get emphasized.

Also, Consumer Reports is recommending the 5 series for those of you who are contemplating buying one. Check out their reviews, new and used.
 

·
Registered
Joined
·
1 Posts
I have a 2008 535xi and the yellow engine light went on last night associated with a very rough engine idle. The dealership's closed due to the holiday weekend so I thought I'd throw this out to the community. Any thoughts? Thanks.
 

·
Registered
Joined
·
36 Posts
power problem

hi i have a problem on e60 530d 2004 when the car is warm and accelerate full throttle from being stationary the car doesnt go beyond 3000 rpm and takes its time to change gear, any ideas
 

·
Registered
Joined
·
1 Posts
Hi to all BMW fans.
Im prou owner of E60 530d. Ewery thing is in order, but im having trouble with noise in uper left part of the dash board. Sound like wnen U grind plastic with a metal stick. Its seams like boults loosen up. Where can i find schematics with boults positions to check.

Thanks!
 

·
Registered
Joined
·
2 Posts
Bmw 530I 2004 problems

Ok 2 things i need opinion about before i take it somewhere and they rip me off.

At low speeds my car has some vibration , if im going at a constant 60 km/hr the car tends to vibrate a bit and the steering wheel shakes.

When i accelerate from like 0 - 60 and i let go i find that sometimes my car stays reved up and takes a while to come down. My fuel consumption meter also stays up even though i let go on the gas. Anyone with similiar problem?? I thought it was the transmission but it shifts normally wen im accelerating so im confused. Can anyone provide help
 

·
Registered
Joined
·
51 Posts
This has been a very interesting thread to read. I'm contemplating buying a 2006 530xi that has just over 48,000 miles on the meter, so this has been very informative. I have to give Silver4evr a lot of credit for keeping this thread going and updated. Thank you. This kind of thing is what is best about these forums.
 

·
Registered
Joined
·
10 Posts
About issue #1 if you have aftermarket rims or had tires replaced recently have them balance checked, then see if you happen to need a centering ring.

Otherwise you could be experiencing shock/strut replacement, or the connector rod bushing being worn out.

Issue #2, can you define a while? seconds or minutes? I have had similar issues lasting only like 5-10 seconds while I am in DS mode.



Ok 2 things i need opinion about before i take it somewhere and they rip me off.

At low speeds my car has some vibration , if im going at a constant 60 km/hr the car tends to vibrate a bit and the steering wheel shakes.

When i accelerate from like 0 - 60 and i let go i find that sometimes my car stays reved up and takes a while to come down. My fuel consumption meter also stays up even though i let go on the gas. Anyone with similiar problem?? I thought it was the transmission but it shifts normally wen im accelerating so im confused. Can anyone provide help
 

·
Registered
Joined
·
10 Posts
My only real issues with my 04 545i, is those darn squeeky windows..

If anyone has a cheap source to get the new window seals it would be appreciated having the contact info.
 

·
Registered
Joined
·
14 Posts
It is hard to believe all you people are having so many problems. Hopely newer models don't have those issues. I am afraid 535 do have fuel related problems due to turbo, I assume. I hear 528i is solid! Good luck with you guys in love with Bimmers. For sure it is an ultimate driving machine that everybody enjoy driving.
 

·
Registered
Joined
·
4 Posts
food for thought

having had a fair range of bmw's e30 2.3 -e28 2.0 -e34 2.0 -e39 2.8 and now e60 545.....i thought i had a gem.....mystic blue cream leather etc..
started having problems with i-drive,sat-nav,blue tooth cd player radio & the screen playing up intermitently......i found water in bottom of spare wheel well (not used due to runflats) after having crytical electronic system failure show up on i-drive screen whilst traveling in outside lane of motorway.......engine faltered, steering went tight etc...due to partial close down of electronic systems.....
being quiet handy with situations i bought a new control module,cleaned all connections dried out the well and found all items now were working....
the main $tealers said the new part needed to be mapped into the on-board computer...well if they service the vehicles they ought to know so i booked it in....the agent advised there may be a few hiccups as the mapping means any available programme upgrades will also be added but at times they do have issues with this up grade......quoted £150.00 + tax
after three attempts to complete work i am told that there is a problem with my m.a.s.c unit (audio controller) and if i want my car back functioning as it did before they touched it (all items working) it will cost me £2065.00 inc tax
this i declined at this time.....
i collected my car from them to find partial up-grade of software with the bluetooth and cd player not working....still debating how to approach BMW customer service without telling them what i think of their agents....
any constructive criticism gratefully recieved
 

·
Registered
Joined
·
1 Posts
530xi wagon rear hatch lift problems

Hi, My 2006 530xi wagon's auto lift rear hatch is having problems. The problem began with the hatch not remaining in the fully opened position after opening normally via the automatic opening mechanism. With in a few days of doing this, the problem got worse and the hatch would only open about 3/4's of the way and then begin to desend. It seems that the hydraulic system is not developing the needed pressure. Now when more than one passenger is in the rear seat the auto-level suspension system pump runs but can't level the car and the error light comes on. Is it possible that these hydaulic systems are related?

Has anyone experienced similar problems? It appears that there is a small bit of fluild that has leaked from the strut that lifts the hatch but it is only a few drops so it doesn't seem it is enough to make a difference.

Does anyone know where to check the fluid level for this system?
 

·
Registered
Joined
·
51 Posts
Ended up buying an X3. Lovvvvvvvvvvve it!
 

·
Registered
Joined
·
1 Posts
1) I also broke my cup holder on my 2004 525
2) Broke the cigarette lighter when I was plugging in my cell phone charger (snapped off)
3) Have another problem would like peoples' feedback on. When I drive, especially on the freeway, it feels like the wind is whipping the car around even when there is no wind at all. In fact, every little bump or maneuver seems to cause the car to sway significantly. I am almost getting nauseous when I drive it. Maybe I am crazy, but my wife agrees with me. Its not the tire alignment, because the car will drive straight ahead without veering. I recently dinged my front light and bumper (a long story) and got it replaced, but I can't see how it would effect my car in this way.

Any thoughts? The suspension? Shocks? I now that the 7 series had problems with the shock absorbers...

Thanks.
Damn I feel sorry for you guys, you spent so much money on the new car and its giving these troubles. I think BMW needs to spend more time testing there cars and releasing them later on. I think they felt pressure due to new E-class release in 2002-2003. And also they were pissed at the Lincoln LS doing an AD which specially attacked the E39 5 series, with head-on camparsion in all handling/powertrain and price category. North American owners probably know about this.
 

·
Registered
Joined
·
1 Posts
Its BMW's fault for not testing the suppliers products. WTF
Ok... With todays standards... I'm almost positive that more than we even think or.. have talked about in the forum goes on to test the product line and producers of such parts that consist of a BMW. One thing that cant exactly be replicated.. due to time and its lact of practicality.. is longevity of a part... and or probability that it might fail. For example... BMW cant test 100 cars with the same parts.. to see how many out of those cars' parts will fail. Its not pratical.. so every now and then you might get a bad egg out of the batch. And if it is a vital part that is the part that fails.. a part will cause others parts to not work at or near their intended operation.
 

·
Registered
Joined
·
4 Posts
Problems

Mine is a E60 Late 2007 520d with the tweaked engine.

Problems:
Fuel System Problems (BMW Admitted Flaw-Replaced)
OBC Issues (Replaced)
Bluetooth connect ability failure (Replaced, cost me nearly 2.5k US)
The bluetooth is a big problem, since i live in Taiwan, every part is exported therefore twice as expensive. The Bluetooth was alright and working before my 50k checkup, and when the car came back, which they resetted the computer, the bluetooth stopped working. This really sucks, because I have to pay for that.

I got really pissed off therefore the manager gave me a lifetime 30 percent off for all maintenance :))
 

·
Registered
Joined
·
2 Posts
Yes agree in your Active Drive System Failure.
Dealer replaced "valve block “reappeared and another valve block.
What is color of Exhaust Gas?
PREVENTATIVE VEHICLE MAINTENANCE
 

·
Registered
Joined
·
4 Posts
Hi,

I have 2004 525i E60. on my iDrive screen additionla information window which is in the left part of the screen disappeared and I cannnot swith it on.

When I go to Navigation the screen is totally black. All other fields, communication, climate and entertainment are working. Can anyone help with this?

Maybe someone hhad similar issue.
 
61 - 80 of 83 Posts
Top