BMW Werkz banner

1 - 20 of 51 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Good morning all,

First off, let me apologize if this has been discussed and if so, I would very much appreciate a link. Now, with that said, I have a 2006 550i with about 53k miles. I am the second owner. I have owned the car for about 6 months/6k miles and haven't really had any problems (other than a problem with the a/c fixed under warranty). I am having an intermittant problem (I know, the worst kind). What is happening is that I am getting a yellow triangle inside a circle and the word "brake" in yellow on my dash See attachments). When I look at the service indications in the iDrive system (in the nav window area), there are two messages. The first is "Drive control system! Drive modera . . ." When I click on this message it takes me to a screen with a message that says "Driving Stability - Drive control system malfunction. Reduced driving stability in curves. Drive moderately! Have the system checked by the . . . "(you get the idea). The second message in the main "service" indicator area says "Start-off assistance inactive!" When I click on it, the next screen says "Start-off assistance - Start-off assistance inactive. Caution, vehicle may roll back! Have the system checked by your BMW center at the next opportunity." The car does NOT go into limp mode and appears to drive normally. The really strange thing to me (I'm very familiar/experienced with servicing my past cars/trucks/motorcycles) is that when I plug in the code reader, it shows no trouble codes. Oh, and about a month or two ago I received a flat tire warning, but didn't have any flat tires. I shut the car off; looked at all the tires; restarted the car; no more warning light (don't know if that has any relevance to my current problem, but thought I would throw it out there). So, anyone have any ideas about what could be causing this intermittent set of warnings? Any help would be greatly appreciated; like I said, I typically work on my own vehicles and I would prefer to diagnose and fix this little issue as well. Thanks in advance :)
 

Attachments

·
Registered
Joined
·
16 Posts
Discussion Starter · #2 ·
Okay, I have just determined that each time the warning ligts/indicators come on, it is immediately after turning the steering wheel (if that helps).
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #4 ·
That's what I'm thinking, module, relay, switch, sensor . . . but I am hoping that this particular set of problems and timing with the steering input will provide enough information for someone to pinpoint which one :wrench
 

·
W00T
Joined
·
2,714 Posts
that yellow light is for the traction control system. If both the yellow triangle and brake light are out it means the entire system is disengaged. You can do this manually by holding down the DSC button for 10 seconds.

Under normal circumstances the only time it should turn on is if you are trying to spin tires or are taking corners very fast and the system fully engages. The light is there to let you know that it has corrected your driving.

If it is on all the time that means there is a malfunction in the traction control system. (it was Dynamic Stability Control for my 330, not sure what they call it now).

There should be a page in your manual stating when the light comes out that there is a malfunction in the system.

Are you going to try and solve the problem yourself, or are you just diagnosing it before taking it to the dealer?

The system works by sensing differences in wheel speed basd on the position of the steering wheel and speed of the car. So possibly the sensor for the steering wheel has gone bad?

Im not exactly sure where that is, but you might want to try realoem.com
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #6 ·
I'm hoping to diagnose and fix w/o heading to the dealer. I will use the recommended site to locate the part (if and when I can figure out which part needs replacing). Thank you :)
 

·
Registered
Joined
·
138 Posts
hey Waterfreak 66, I had the exact same thing happen to me about two weeks ago, I just went to the dealer and they replaced, its covered under warranty.

Im trying to read this service invoice and it is really hard to decipher, but I think the part number 54499, states faults code is 5EBA DSC: steering angle sensor; Fault code A85D, stated to replace the following component: steering column switch cluster.

Hope this helps.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #8 ·
Thank you soooo much. My car is out of warranty so that's why I'm trying to track this down myself. Now I'll just have to figure out if that is 1 or 2 different parts and how to replace it (them).
 

·
Registered
Joined
·
66 Posts
The first is "Drive control system! Drive modera . . ." When I click on this message it takes me to a screen with a message that says "Driving Stability - Drive control system malfunction. Reduced driving stability in curves. Drive moderately!

I am not very clued up with these models but if your car has electronic damper controls that stiffen suspension up when cornering would it be a fair bet to say your shocks are tired and the system is operating on the edge of its working parameters ??
 

·
Registered
Joined
·
27 Posts
you can diagnose the car with out a scanor cam/bus or gt1 or others who can read abs and traction control system and body control b/c it sounds like you have a bad abs sensor on the wheel or pulse pump abs sensor or steering angle senor so it not something you can do, you must go to a professional
 

·
Premium Member
Joined
·
1,052 Posts
It may be a bad SZL (steering angle sensor) but even if you replace it you will still need take it to the dealer to be programmed.
 

·
Registered
Joined
·
1 Posts
just had my steering angle sensor replaced. it was a $1000. repair and i am out of warranty. ask dealer to talk to BMW and tell them that this isnt a wear and tear item. they hooked me up. if it is the steering angle sensor the wheel would be tilted to the left when driving strait.
 

·
Registered
Joined
·
28 Posts
I see the same error messages

Hello,

My wife just got me a 2006 525i and I'm getting the same yellow lights (errors) as the WaterFreak has. The first time yes, I was "testing" the car around the corners. The errors went away after I shut the ignition off, pulled the key out.
The second time, I was just stopped at a red light waiting. The car in front of me rolled forward slightly so I did the same. As I rolled forward, I turned the steering wheel slightly and that's when the yellow BRAKE and yellow triangle with a circle turned on.
Should I have the car checked? I just got this from a used car dealership (Carmax) 3 days ago. What could be the problem?


EDIT: BTW, on the printed manual that came with the car, the error is there noting that the yellow lights are a malfunction and should be taken to the dealer. However, when I download the manual from BMWusa.com, that section is not there. HHHMmmmmm....

Thanks,

Balbs


P.S. I just registered right now and this is my first post.
 

·
Registered
Joined
·
28 Posts
Yes, we got a 5 year or 60K mile warranty. Aside from that, any faults or maintenance within 30 days are fixed for free. I just want to know for myself and gather info to help their techs out since I don't think they have a dedicated BMW service tech...or do they??? (That's another topic I guess).

Balbs
 

·
Registered
Joined
·
28 Posts
BTW, how long would it take a BMW tech to troubleshoot this or replace a module, relay, etc...? Is a day enough time?

Balbs
 
1 - 20 of 51 Posts
Top