BMW Werkz banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
hi, i have a 1999 e39 523i. the speedo and the analogue mpg dial are completely not working. the digital mileage readout is not working either, its been the same for ages. i have changed my speed sensor, everything seemed fine when i took it for a spin then when i turned the engine off and tried again, it stopped working again, so im back to square one. i have been told i need to change my speedo unit, or get a new ecu and most recently need new abs sensors, all from different mechanics. the diagnostic apparently points the to finger at abs sensor.

any advice would be greately appreciated, im desperate to get back in my car, its been sat idle for ages.

many thanks :)
 

·
Registered
Joined
·
87 Posts
most likely there si a problem with cluster if the, abs was defective there would be a abs light on with a code, if the speed sensor was bad there would be a check engine light on, with a code saying so , but a 523 sounds like a euro version . i dont know if they use the same obd same as U.S hope it helps
 

·
Registered
Joined
·
82 Posts
Yep, i'd agree, to a point. The ABS light should be on if it's an ABS wheel sensor, but that's the only thing missing, the diagnostic of left rear ABS wheel sensor gave me all of the above symptoms. It was actually the cable that was chafed through in quite a few areas. Have a look at the cable. it comes out easily you can check for shorts etc and maybe fix it up. Does the ABS light work? Does the ABS work?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
thanks for your responses harryinsaudi and westin

the abs light on the dash never comes on, even with the ignition switched on. its been like this since i bought the car in july 08. the speedo unit has been tampered with, the seal is broken. perhaps the seller removed the abs light to help disguise the fault as it was intermitent at the the time. im not sure if the abs is working.

i will check the cable connecting to the abs sensor, if that is ok i will change the abs sensor itself.

just to confuse matters further, a specialist (re reman) are telling me its likely to be the 'abs ecu/control unit'. its a bosch part and they refurbish it for around £100. any comments on this would be appreciated
 
1 - 5 of 5 Posts
Top