BMW Werkz banner
1 - 12 of 12 Posts

· Registered
Joined
·
14 Posts
Discussion Starter · #1 · (Edited)
Hi all, how r u?!

i have a strange problem with my E39 :conf

this is the case exactly:

sometimes when i switch the car on, the headlights work automaticaly (without switching them on) and due to that, the signal lights stop working as well as the back lights!

and the lights Switch do not response at all

i went to an electrician and he reset the computer by unplugging the battery cable! after that it went away!

then again after like 10 minutes it happened again... but this time in a different theme :help

the second time, when i switch the lights on the right signal works by it self!!!

i thought it may be the computer board of the lights and checked it and it was OK!

so now i ended up resetting the car everytime this happens!!!!

any idea's!?!? did this happen to anyone of you?!?!

Thanks All!
 

· Registered
Joined
·
1,493 Posts
Hi all, how r u?!

i have a strange problem with my E39 :conf

this is the case exactly:

sometimes when i switch the car on, the headlights work automaticaly (without switching them on) and due to that, the signal lights stop working as well as the back lights!

and the lights Switch do not response at all

i went to an electrician and he reset the computer by unplugging the battery cable! after that it went away!

then again after like 10 minutes it happened again... but this time in a different theme :help

the second time, when i switch the lights on the right signal works by it self!!!

i thought it may be the computer board of the lights and checked it and it was OK!

so now i ended up resetting the car everytime this happens!!!!

any idea's!?!? did this happen to anyone of you?!?!

Thanks All!
you have a broken ground wire in your system. Or, the ground wires that are bolted to the frame have corroded.

Everytime you reset the computer/module to ZERO state, it functions fine until the logic is disrupted because it cannot find ground where needed. That's when your probs arise. ughhh. breaks in wires can be a pain... :-(

What year is your car?

TiP: ground wire in bimmers is SOLID BROWN . you might try looking there to start

**Then also, make sure the light switch is actually working alright. There are cases where u have voltage "jumping" from 1 terminal to another inside of the switch...it's caused by arcing deposits accumulated over time.
 

· Registered
Joined
·
14 Posts
Discussion Starter · #7 · (Edited)
Thanks All

Thanks all for your replies and answers, appreciate it!

i will write everything happened with me for extra knowledge..it may help someone else sometime

i went to the technician on thursday and he checked the instrument cluster and found nothing, the wires and found nothing and checked the cable connector and found nothing and also checked the ground wires and found nothing also!!! :eek:hnoes

after all that he suggested to replace the LCM and put a new one just to see if the problem will consist or will it go away!

and when the LCM was replaced the problem went away!

so i told the Guy to reinstall the Old LCM, just to make sure that it is the LCM that is causing this...., and when he did.. also everything was OK! :conf

anyways, i tried it for like 2 -3 hours and the problem came back, so i went back and installed the new LCM module and told him that i wouldnt pay untill i try it for a week! and mysteriously..he agreed!

So far after installing the new LCM, everything is good.. if it was good till next thursday im going to pay for it!

Thx All for your Help
 

· Registered
Joined
·
14 Posts
Discussion Starter · #9 ·
I think BMW is designed to switch the lights on if the LCM is disconnected or faulty. This is an advantage that shows BMW is a well engineered vehicle
Totaly Agree, as an Emergency light.... that is what the tech. told me

that the LCM would switch the lights On when it has an error just in case you were driving at night.

But Again.... why to put a thing such as the LCM?! :conf

all cars have lights and xenons.. non of them has a an LCM!!!

you know, i had a CL 500 and sold it just to get rid of these complicated technological Stuff!!!!
 

· Premium Member
Joined
·
1,706 Posts
Totaly Agree, as an Emergency light.... that is what the tech. told me

that the LCM would switch the lights On when it has an error just in case you were driving at night.

But Again.... why to put a thing such as the LCM?! :conf

all cars have lights and xenons.. non of them has a an LCM!!!

you know, i had a CL 500 and sold it just to get rid of these complicated technological Stuff!!!!
Most high end cars have this kind of technology. BMW's might not be as painful to work on in comparison to Mercedes Benz but they're both equally complicated when it comes to electronics.
 

· Registered
Joined
·
1 Posts
I'm having issues similar to what is described with the lights but I'm also having the lights flickering like it has a bad ground or a bad switch. If it is the LCM that is bad, would the lights flickering be another common symptom of a bad LCM? Also, Where is the LCM located? The pictures I'm seeing is not giving any location.
I'm also reading that the LCM will need to be programmed with the same mileage count and in order for it to be programmed, the new LCM will need to be equipped with the same program version.

Any advice would be appreciated
Thanks for your time.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top