BMW Werkz banner
1 - 5 of 5 Posts

· Registered
Joined
·
101 Posts
Discussion Starter · #1 ·
Ever see a fuel pump do this?
<see attachments>
Sorry one is a bit blurry - my batteries died before I could ge a better pic.

This came out of my 1991 535i.

I replaced the pump yesterday and this is how it looked when I pulled it out.
This might very well be the reason for the intermittent starting problems I was experiencing - especially when the weather cooled down a bit (I have an earlier post on this forum).

I'll finish up tonight working on it and I'll run it for a few days and see what happens.

The pump is very easy to replace but I was also in the middle of changing out the Crank Position Sensor and I don't have the cooling fan put back on yet.
 

Attachments

· Premium Member
Joined
·
14,769 Posts
Is all of that plastic surround still in one piece? Maybe it was bouncing around and self-destructed?

We changed the pump in my dads 535i last weekend and the thing wasn't even clipped in. :conf
 

· Registered
Joined
·
101 Posts
Discussion Starter · #5 ·
Nope - it was all snug and secure inside the plastic housing. I had to push on the latches on both sides to get it out of the housing.

I did replace the in-line filter as well as the pump.
I'm wondering if the filter was getting clogged and it over pressureized. But that seems like a lot of pressure to do damage like that.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top