BMW Werkz banner

1 - 13 of 13 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
I just bought a 1994 bmw 325is and one problem I have is the coolant check light comes on every once in a while. I am not sure why. It happens for no apparent reason. Sometimes when i start it up it comes on and some times when i turn it off it comes on. Any suggestions on what i should do would help me greatly.

Thank you.
 

·
Registered
Joined
·
698 Posts
hmmmm maybe you need some coolant
 

·
Registered
Joined
·
46 Posts
Discussion Starter #4
Maybe but why do i need some for one time and not the other. does it magicial fill up by itself?
 

·
Registered
Joined
·
698 Posts
could be how your car is sitting, if you are leaning toward the sensor all the coolant will be on the sensor. If you tilted away from the sensor it will tell you to check it.
 

·
Registered
Joined
·
2,907 Posts
happens to me too when it's really cold. I bought a gallon of antifreeze and topped it off when nessicary. once a month adding just a bit shouldn't be too often to cause alarm.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #9
That might be a good idea cadete905. I have not thought of that. Do you know where the sensor is located?

Thanks for you help
 

·
Registered
Joined
·
5 Posts
Mine does the same thing... but mines is on all the time. Look right down the coolant tank and you should be able to see the sensor if I'm not mistaken.
 

·
ex owner/admin
Joined
·
10,839 Posts
Originally posted by cadete905@Feb 10 2004, 05:01 PM
check your sensor floater in thank gets bad after a few years
i dont believe 1994 325's had the floating sensor. however it very well could be a sensor problem on the expansion tank.
also try to bleed the system , you could have air pockets circulating in the system, this is a common problem when a non-bmw mechanic does any coolant flushing (ie midas or whoever the generic auto mechanics are)

lastly try adding some coolant :lol:
 

·
Registered
Joined
·
909 Posts
its a common problem, my car does it every once in a while also and my dad and i have been through my coolant system time and time again and it runs fine. Its all in the sensor.
 

·
Registered
Joined
·
10 Posts
My 95 325i has done it each year when it gets cold. this year it has done it more than normal and my mechanic at the dealer says my radiator is seeping. so another option besides adding coolant and the sensor could be the radiator beginning to go. I haven't replaced it yet so I can't tell you anymore.
 

Attachments

1 - 13 of 13 Posts
Top