BMW Werkz banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello All,

I'm new to this forum and new to E-36 ownership. Recently purchased a '96 328i sedan. It's a 5-speed car. It's had a hard previous life and needs work but I couldn't resist after driving it.

One of the things wrong with it was the climate control wasn't (still isn't?) working. I researched some common issues and found out about a capacitor that goes bad on the circuit board. The unit was acting as was described in the thread so, I disconnected the battery and removed the module, replaced the cap on the circuit board and then re-installed it. Now, it seems to work - all the lights work, the display works, the fan control, temperature settings, etc. I can hear the blower motor running but, no air comes out of any vents regardless of what air flow setting is selected on the unit. Hot or cold - nothing. Any ideas? Could the cabin air filter being plugged up cause this?

Before I removed the climate control module, the central locking system worked. After I plugged the climate control module back in, the central locking system stopped working. What's worse is the lock cylinder on the deck lid is damaged and cannot be locked or unlocked with the key. It was unlocked though so just pushing in the cylinder opened it before. Now, the deck lid won't open either. Did the central locking system lock it? Any ideas on how I can get it open? ANY ideas, I already have a spare deck lid :) I picked it up cheap just for the lock cylinder. It's got a few dings in it but...

Love this car - couldn't resist buying it after I drove it. Even with the problems it has it is very peppy and responsive. Should be fabulous after I get it all fixed.

Thanks in advance for the help!

David
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #2 ·
Doh! OK - the Central Locking issue is resolved. It was a blown fuse. Although, the fuse panel stated it should be 5 amps and it blew a 20 amp fuse...

Anyway, deck lid opens now.

Doh! Sorry, next time I'll check the fuses. It's the weather, brain can't function in such cold temperatures...

Thanks,
David
 

·
Premium Member
Joined
·
14,730 Posts
Glad to see you're getting it sorted. But there may be a short to hunt down to keep it from blowing more fuses.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Yes, there may be a short. Central locking stopped working again last night. Haven't checked the fuse yet...
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
OK - the climate control and air distribution. I changed out the cabin air filter but still no air coming out of any vents.

Anyone have any ideas?
 
1 - 5 of 5 Posts
Top