BMW Werkz banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi, glad to have found this site, and sorry for going straight into asking for help, but I have a pretty bizarre problem. I have just moved to France, and brought my 1999 728i over with me - it's too good to leave behind.

I needed to convert the headlights to cover driving on the right, and bought a nice set of new Angel Eyes from eBay. Had them fitted by a local garage two days ago - didn't want to do it myself in case I messed up.

The lights look great - problem is that when you start the engine, after about 10 seconds the low beams start flickering like mad. Main beam works fine.

Local garage have thrown hands in the air, and said it must be a BMW computer issue.

Drove to main BMW service agent in Cognac yesterday - they say they have never seen anything like it, and that as these are not original BMW supplied headlights there is nothing they can do!

Searching the web I can see many comments that this sort of problem may be caused by a short somewhere, or a badly fitted tail lamp? Not sure how to trace this - one other clue is that the dash warning has come up for 'Check lowbeam lamp' which sounds like it can detect a problem during the normal round of prechecks.

Can anyone offer me some advice on how to proceed - it will be very gratefully received - in English or in French!

Cheers - Tim.
 

·
Help from over the pond
Joined
·
3,239 Posts
So do you have the original BMW headlights fitted or aftermarket ones??
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
extra info

Sorry, I should have been clearer - I bought replacement housings set up for driving on the right (with angel eyes) so the original (halogen) housings have been removed (I still have them) and the new housings put in.

The garage also charged me for two new H7 bulbs, so after reading around a series of other posts, I'm wondering whether these new housings with the angel eyes in are setup up for Xenon, otherwise why would they fit new bulbs?

I found this on another forum in response to a similar problem: "Your car came with halogen headlights I assume. You can try getting some cancellers or making a harness, but they will not work plug and play. The reason they flicker is because the check control system is sending pulses to determine if your lights are working. It has nothing to do with your kit, and everything to do with your car."

Just checked the bulb boxes, and they are halogen bulbs. So I'm guessing it is something to do with the check pulses from the control unit, but not anything to do with Xenon/HID technology?

Do you think the capacitors shown here might work?

HID Anti Flicker Capacitors - Error Code Canceller (1 Pair) - Stealth Auto
 

·
Help from over the pond
Joined
·
3,239 Posts
Hmmmmm...I don't know why you were told to replace the headlight units as there is a flick switch inside which changes the beams left to right anyway,I do it every time I drive from the UK to Europe 30 second job at the ports each side..... as for the problems your having with the flickering I'm not sure if its bad wiring, the angel eyes should be wired in to the sidelights, could you post a couple of pics exterior and interior of the units with the rear access caps off..
 

·
42, The meaning of life
Joined
·
2,405 Posts
Welcome to the Werkz. Good luck with your problem, it sounds like it will be something simple to fix, but maybe not easy to pinpoint.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Issue resolved

The saga is over.
Checked with the guy who supplied the lights; he says he sells xenon and halogen, but the ones he sent me are definitely halogen.
There is something that looks suspiciously like a ballast behind the low beam unit, but what do I know...
Order the anti-error box from an eBay site in the UK; my PayPal account has been suspended and I cannot pay for them. Its going to take weeks to sort out PayPal.
Locate another supplier in France and send off a cheque. They arrive two weeks later; plug and play, but apparently not for my units.
Check the old units for the switch to change between left and right beam direction. Its not there (wanted to confirm this as I couldn't find the switch before I had them swapped out). Check with my UK technician - he confirms the switch isn't always there - depeneds on what units are in there. Possibly these disappeared in the facelift version?
Anyway - find a car electrician and get him to check the new units and my shiny new anti-error boxes.
It seems my lowbeam are xenon and the highbeam are halogen. Seems weird to make a hybrid box, but again, what do I know?
He cuts the plugs and rigs up one side, and hey presto - it works, so he wires them in properly, and I'm one happy beemer driver again.
Next week the controle technique!
 

·
Help from over the pond
Joined
·
3,239 Posts
At least youve got lights again, Ive double checked about the switch and your chap seems to be correct they did away with it on the facelift model, which in my opinion was a silly move as loads of people cross the water everyday...such is life.If get a F/L model I will be putting pre F/L lights in as I go to Belgium and back approx 20 times a year...
 
1 - 8 of 8 Posts
Top