BMW Werkz banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi, my car is a 94 325is. Sometimes when I turn on and turn off the car, the computer displays "check coolant level, see owner's manual", I checked the coolant level and it's about normal, and I don't have an owner's manual. The computer also displays "washer fluids low" when it's not low at all. Anybody know where the problem is?

thanks!
 

·
Registered
Joined
·
25 Posts
a common problem with the coolant issue, is the float at the bottom of your overflow res, gets gummed up, and cant freely float around. so the fix is either take out that float and clean it up, or buy a new float. the float sensor is cheap and you can buy it on www.bavauto.com. probably the same problem with your washer res.
 

·
Registered
Joined
·
49 Posts
did u just buy this car or its just started to do that.sumtimes in front collision shity body guys plu things in wrong or forget too check all the wires u never know maybe a bad sensor
 

·
Registered
Joined
·
26 Posts
did you at any point actually ADD coolant to the reservoir ... it may LOOK ok but may actually be low ... add coolant first then revisit ...
 

·
Registered
Joined
·
23 Posts
aahhhh onboard computers

A friend of mine had an Audi that displayed "Check coolant" and when he added Steering fluid, the signal disappeared :blink:

A year later, same thing although I don't remember what it was, but the computer told him that A was wrong, he fixed B and boum, problem solved.

I'm not sure why, he isn't either. Just a weird car...

So check everything :laughhead: and get the car to the dealership, they are used to it, and they might just reset the computer, and ask you to come back if it flashes again.
 
1 - 7 of 7 Posts
Top