BMW Werkz banner

1 - 16 of 16 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have this 94 325is with a 95 325is engine and recently the fuel gauge won't work anymore. It just stayed on empty and won't move. I was wondering if there is a blown fuse or something. Does anyone know how to fix this problem without going to a shop?
thanks.
 

·
Registered
Joined
·
1,819 Posts
Check your fuses, then let us know...
 

·
Registered
Joined
·
5,973 Posts
is it possible the needle is stuck?
 

·
Registered
Joined
·
2,326 Posts
Could be the floater in the tank no longer floats.
 

·
Registered
Joined
·
1,819 Posts
Maybe its out of gas?
 

·
Registered
Joined
·
2,326 Posts
Originally posted by Asio@Dec 6 2003, 01:06 PM
Maybe its out of gas?
:lol:
 

·
Registered
Joined
·
698 Posts
If you didn't turn your car all the way off when you filled it up this is known to make the gauge act weird.
 

·
Registered
Joined
·
5,253 Posts
ur sensor could be bad
 

·
ex owner/admin
Joined
·
10,839 Posts
Originally posted by whitebeemer328@Dec 6 2003, 10:18 AM
it may be a connection on the back but most check it or sending unit in the gas tank.
im inclined to agree with white on this one, hit the gauge pod with your hand to see if the needle jumps to eliminate elpresidente's suggestionh
 

·
Registered
Joined
·
12 Posts
mine di the same thing last nite, i filled up everything was cool. parked the car and came out later to go out and the needle moved up for a sec then dropped and stayed on empty. came back about 2 hrs later and everything was back to normal, and still working this morn.
 

·
Registered
Joined
·
5,973 Posts
i use shell.

Is there something in it that can cause this problem?
 

·
ex owner/admin
Joined
·
10,839 Posts
shell is notorious for causing probems with cars, all i know is there is some additive that causes problems with the fuel pump and relays, really thats all i know.
actually at work our fleet services (thats around 5000 trucks) advise against using shell for the same purpose.
 

·
Registered
Joined
·
5,973 Posts
hmm, so I asume that Texaco is out too then? and isnt Exxon also part of Texaco, which was purchased by Shell?

OMG, I have nowhere to get gas now! I'll be forced to go to Citgo or Conoco.
 

·
Registered
Joined
·
49 Posts
Okay, this is dumb but the same thing happened to me. I just ran some Lucas fuel system cleaner and it's now working. Now, the Lucas could have absolutely NOTHING to do with the gauge but it started working again and still does. Possibly the thing that the floater attaches to was gunked up but this seem unlikely. But alas, it works so you might want to try it.
 
1 - 16 of 16 Posts
Top