BMW Werkz banner
1 - 16 of 16 Posts

· Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
hi all
i am new to bmw`s i have a problem with my service light indicator
i have just given it an oil+filter plugs and air filter change
and the service lights will not reset i read it could be a problem with the nicads on the si board if i new where it was i can replace the nicads

can any 1 help please as its drivin me nuts lol

thanks in advance:conf
 

· Help from over the pond
Joined
·
3,230 Posts
What did you try and re-set them with ??
 

· Help from over the pond
Joined
·
3,230 Posts
Did you do it this way....

To reset the indicator lights:

Ign off, connect pin 7 (si reset) to pin 19 (gnd).
You can put an inline fuse or resistor in your bridging wire to be safe
Turn Ign to pos 2
remove wire or turn off Ign after about 5 seconds for an oil reset, 10 secs for an inspection reset.
May take a few goes to get the timing right!
 

· Help from over the pond
Joined
·
3,230 Posts
I think you are possibly correct, if you know someone with a re-set tool may just be worth giving it a go.
 

· Help from over the pond
Joined
·
3,230 Posts
As far as I know the SI board batteries are directly behind the Service Indicator lights, if they have gone the last service lights up will stay there as they are memorized, so Im sure this is your problem.
 

· Help from over the pond
Joined
·
3,230 Posts
Where do you live as Ive just realised by your house you must be in the UK ???
 

· Help from over the pond
Joined
·
3,230 Posts
Ok now I know you have an E39 UK spec...? there are no nicads, you really need to purchase a re-set tool ...ebay around £10 to £15.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top