BMW Werkz banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Hi all,

i was wondering if someone could help me with the following:

the car is bmw 318 ti compact automatic 1999 model. since yesterday i'm trying to find out/fix a start engine problem. it cranks, but will not start. started first time when jumped from another vehicle. battery seems fine as all the lights come on bright when you turn the key (also once jumpstarted i have driven it around 50 miles on the motorway, so it would have recharged it). alternator seems fine too (as it didn't stall while waiting at lights) checked all fues - fine. when i crank it there is kind of a clicking noise coming from around distributor/front fusebox area. makes me think it might be a relay or something along this path. i have given up now as i am only competent up to a very modest level. decided to post here if someone can come up with something simple that might be the problem, before i take it down the dealer (which is closed today anyway):(

thanks
 

·
Help from over the pond
Joined
·
3,239 Posts
Sounds like the battery hasnt enough cranking charge, hence when jumped it will start 1st time, if the battery is over two years old and youve been doing small journeys...stop/start or a lot with lights on, I would say time for a new battery.

ps. make sure to get the correct battery it will have the ampage on the battery eg; 90 AMH
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
thank you so much,

yes the car has been used for journeys up to 5 miles a day for the last maybe 10 yrs. i changed the battery on it 4 years ago. now someone said it, i will go and get a new one (its 50 Ah). just out of curiosity (excuse my incompetence) - but wouldn't a long trip charge it....

i had a similar problem on a golf a while ago and it was the earthing of the alternator gone disconnected, however the BMW is so packed under the bonet, i cant see a thing...

once again thanks for the reply!
 
1 - 3 of 3 Posts
Top