BMW Werkz banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello there. Two weeks ago I got my first 2001 BMW 525i and I love it!
Four days ago I've replaced front break pads with a new set and the lights I've mentioned above came on. I had some one hook it up to an expensive computer and performed a detailed scan of the car. His computer at first said "Open circuit on the left front pads sensor," but then he and erased all the trouble codes and no faults were discovered. After all, the lights were/are still on. He said: "Oh, some times you need to drive the car for at least 50 miles for the light to go out. It's been 70 miles and nothing happened. Today I removed the left front wheel and realized that I did not buy pads with censors and the censor wire that is there is tight together and taped closed.
I wanted to reset the maintenance records by pressing the mileage reset button, but the instruments light up like a Christmas tree and all the needles go up and down. After all the light show and the needle dance, the three lights are still on.:conf

Please, tell me what to do or what to expect. Any info will be appreciated. Thanx.
:help
 

·
Premium Member
Joined
·
14,730 Posts
Well you can see how that would be hard to narrow down over the internet. Very glad it's sorted though.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
I turned off the DSC and drove a few miles around town. Then stopped at a gas station and when I started my car again the lights came on. I drove few miles and the lights went out.:conf
 
1 - 6 of 6 Posts
Top