BMW Werkz banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I'm pretty new to this forum, and so glad I've found this place! I've owned BMWs all my life, and enjoy maintaining mine myself...I hope I don't put anyone off by being a girl.

My 97 328i is giving a p1421 code and I can't narrow it down to what it is.

I've done most of the work on my car myself. I keep it nice, always do the oil changes, keep up with brakes, rotors, sensors, fluids and filters. My check engine light has always come on for a day, then off randomly since I've had this car. It could be months between times when it has done this, but the light always goes off. This time however, the light has remained on. I took it to auto-zone and they said it was reading a p1421 error code, but their computer system would not bring up that code for BMWs. I've been doing my research online for this code, but other people typically have this code in conjunction with other related codes, not just a single code of p1421.

Does anyone have an idea of what it could be, or what I need to check? Minor or major?

FYI- It has just hit the 100,000 mile mark.

I've replaced the oxygen sensors around the 75k mark, could they be bad already? I thought they were supposed to last about 100k...so I'm thinking thats not the problem.


Thanks so much for any assistance you can provide.:)
~Ann-Marie
 

·
Premium Member
Joined
·
14,730 Posts
I would look closely through the Google results. I saw a bit about secondary air pump, :welcome
 

·
Help from over the pond
Joined
·
3,239 Posts
But what I would do is clear the code and see if it returns......there again as your engine light sometimes comes on I would say its the pump failed.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Yep thats the code for secondary air system, where and how to do:

Secondary Air Pump Replacement 328i|BMW Blog
Thanks so much. That sounds like the exact problem my car has been having. When I start it up, the secondary air pump has been making a loud vacuum sound for about 3 minutes and then the noise just stops, I guess it was just going out. I've kept an eye on it and it has been working, just a little loud. Time to replace it. Shouldn't be too hard, I've taken it off before. Thanks for the link.
Now I have something to do this weekend.
Many thanks for the help!
~Ann-Marie:)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
I would look closely through the Google results. I saw a bit about secondary air pump, :welcome
Thank you!
I connected the dots...thought it may be the air pump but got alot of google results including the oxygen sensors.
The air pump has been making a lot of noise, but has been functioning fine, I guess it is finally time to replace it.
I have to pass inspection next month and they won't do it with a check engine light on.
Hope the replacement resolves the problem.
Thanks for the tips!
~Ann-Marie:)
 

·
Registered
Joined
·
1 Posts
HI everyone. this is my first 98 BMW 328I str8 6 2.8L manuel trans. I also have the same problem with the P1421 code. Its the only code that shows up.
When i first start the car the system were it tells you whats wrong shows me ext -37 deg f, not sure what that supposed to mean. when the first start in the morning the rpm's jump up to 2 then bounce a couple of times then drops to about 900 rpm's and runs really ruff.
Not sure if both problems are related, but would like some help trying to figure out what to replace to get my baby running right.

it has 199800 miles on it and amazingly strong
 

·
4DoorWhore
Joined
·
2,208 Posts
HI everyone. this is my first 98 BMW 328I str8 6 2.8L manuel trans. I also have the same problem with the P1421 code. Its the only code that shows up.
When i first start the car the system were it tells you whats wrong shows me ext -37 deg f, not sure what that supposed to mean. when the first start in the morning the rpm's jump up to 2 then bounce a couple of times then drops to about 900 rpm's and runs really ruff.
Not sure if both problems are related, but would like some help trying to figure out what to replace to get my baby running right.

it has 199800 miles on it and amazingly strong
That code is related to the secondary air pump. Clear the code and see if comes back. Take a look at your O2 sensors, and check for vacuum leaks. Check ALL your hoses as cracks can be pretty small.
 
1 - 9 of 9 Posts
Top