BMW Werkz banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
The problem with the Transmission seems to always occur when I'm about to come to a complete stop, or in bumper to bumper traffic. On the dash there's a yellow warning light that appear's in the center, when it seems to remove some of the power being sent to the transmission. Example when running normal at 75 mph the avg rpms are at 3k, when warning light appears the car running at 75 mph now is running at a higher rpm rate of around 3.5k. With the warning light, it take quite a bit of gas pedal to get the car moving "very imbarassing" to say the least. Any assistance will be greatly appreciated.
 

·
Premium Member
Joined
·
13,803 Posts
i havent had this problem in my 325 but when i use to own a infiniti q45 i had the same problem, basically my oil was low/bad and i didnt keep chekin and my transmission jus went out, so i would say first thing would be check all of your oils...
 

·
Registered
Joined
·
11 Posts
how do your service meters under the speedomoter read? They might be under the tachometer I forget, it's the series of lights that go from green/yellow/red.
 

·
Registered
Joined
·
52 Posts
I had this problem too on my 93' 325i. When I turned off my engine and waited a few moments (sometimes 5 sec -sometimes 20 minutes) the light would go off again and the power would return. However, eventually this quick fix stopped working and I was forced to take it to the dealer. After diagnosing it, they found an eprom needed to be updated (or replaced). It was only about $300 including labor and could have been a lot worse. They can usually tell by running the diagnosis, but my dealership charges $150 for this. Since then, no more transmission light :D
 

·
Registered
Joined
·
5,973 Posts
one more reason to get a manual....

I would have to agree with the other posts and have the dealer look at it, as it doesnt sound like somtehing you can fix.
 

·
ex owner/admin
Joined
·
10,839 Posts
im still not sure which light is comming on, it sounds like your talking about the transmission liight (should look like a gear with an "!" in the middle [only avalible on autos]) i would take it in to get service, you may just have a problem with the ecu or the relay.
 
1 - 7 of 7 Posts
Top