BMW Werkz banner

1 - 6 of 6 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter #1
i have a beat 84 528e, the front right shock is totally busted, need new assembly(all the shit, strut housing etc...), probably replace all four, the windows are fucked(checked the fuse, not it), the steering before the shocks went needed alignment, the ac was gone, computer didnt work. the car was bought on ebay a few years ago, and as it goes my dad got scammed :thumbsdown , right when we got the car dad had to get the morot rebuilt w/around 90k miles on it- the car evidently went througha flood and all the computer shit is most likely ruined, all the wires need regrounding, dent on fender, plus some wierd shit w/ the rpms- the first few times i start the car in the day the rpms go crazy, from below 1000 to almost 2000!!! fucked up, as the day progresses the prob gets less noticable. the car was laying around unused for almost a year til june 6 when i got my license and a started to use it, we charged the bat for a night and the next day it worked, i was skeptical of bringing it to school cause my dad said something was wrong w/the bat as it could lose all power w/out warning, this never happened, yet until the shock broke i was worried about the prob...well, im thinking of fixing it up and maybe modding it a little, iwas wondering what everyone thought about the condition of the car and whether it would be worth undertaking this project, plus what mods would be good for this car, i have a service manual and am planning to do the repairs myself...
 

·
Registered
Joined
·
2,053 Posts
i think repairing the car to run properly would be the best mod you can do and probably give you the most noticeable difference. there's no point in modifying a cars performance when its in rough shape. but if you get it all fixed up then a chip is a great mod for a eta engine, advertised at around 20-25hp gain.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #4
Originally posted by KC Ron Carter@Oct 26 2003, 12:23 AM
I have had a 1984 325e since new.
The same engine and running gear.

I have changed the differential to a 3.42 to 1 from the OE 2.79 to 1.
With a chip to remove the 5400 redline it is a different car.

Not a racer but fun to drive.



Later,
did you have any of the same problems as me? if you did, could you help me out w/some solutions?
 

·
Registered
Joined
·
82 Posts
If you have idling problems it is probably the idle valve going bad. There is a screw which allows limited adjustment. If that does not work it is probably the valve.
 

·
Registered
Joined
·
2 Posts
Originally posted by E28boi@Dec 17 2003, 08:45 PM
If you have idling problems it is probably the idle valve going bad. There is a screw which allows limited adjustment. If that does not work it is probably the valve.
[snapback]68067[/snapback]​
I had idling problems on my '87, after a metal plate came out from under an SUV in front of me and I drove over it at about 85 as it was flipping. :banghead

Turns out it chopped up the wiring harness near the transmission, which was causing some of the exposed wires to touch the chassis. This #1 caused my engine idle controller fuse to blow, and #2 put a load on the battery when the car was off, draining the battery in about two days time, if the car wasn't started.

I would check to see if your fuse is blown and replace that first if it is. Not sure if the '84 is different, but on mine, if youre looking at the box from the driver side its the leftmost fuse that is closest to you. Should be an 8 amp one. Hope this helps. :beer
 
1 - 6 of 6 Posts
Top