BMW Werkz banner

1 - 12 of 12 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter #1
i was driving w/ my friend in his '96 328is in auto, he tells me to look at the dashboard, and to my surprise the gauge that tells you engine temp is all the way to the right, with the little glowing red light. my friend pulled over and we looked at the engine and there wasnt anything noticable wrong with it...so we decided to drop it off at his house and on the way to his house, the gauge began to read normal again, this repeated until we got to my house(decided the car was in normal order), my friend says the car felt fine and whatnot, he told me this happened before and it was his thermometer which he had replaced, if it was the thermometer again, what would explain the alleged temperature fluctuations??? help me
 

·
Registered
Joined
·
2,326 Posts
Thermostat must be shot. When he replaced it the first time did he have a shop do, or did he DIY it? If he DIYed it he may have gotten the wrong thermostat.

Did you smell something like maple syrup when you where in the car?
 

·
ex owner/admin
Joined
·
10,839 Posts
ahhh you sure theres nothing wrong!! over heating the engine is very very bad, causes one of those dominoe affects on your wallet.. i really would get that checked out, and how long do you guess you were on the red light?

see what can happen is the thermostat could be seized shut or the waterpump not working, (to the eye you cant see anything wrong) now overheating will cause a chain of events to happen (this is personal experience after i hit the red light for only 2 seconds, thermostat)
my thermostat had to be changed,
then the housing
then the waterpump,
then the radiator
then a hose

and hopefully not my head gasket or internal engine parts, (which i dont think will happen because i only overheated for a second or two)

these chain of events happened all because of an overheat plus the fact that these wear products were bound to go anyways (talking waterpump and thermostat) the radiator only blew because when i overheated it cracked and dried out the upper spigot which i believe the return hose from the engine is clamped down. the hose i replaced for extra caution.

guys dont take chances with overheating situations, they can only lead to bad stuff, and this goes for any car, not just our bimmers.
 

·
Registered
Joined
·
3,240 Posts
i had that happen in my 95 328..... on mine it was the water pump.

On the original water pumps the impellors are plastic, and if they starting to break up (plastic fins cracking) the water flow is reduced around the engine, thus making the temperature go up!

Go for an after market pump with metal impellors :thumbs
 

·
ex owner/admin
Joined
·
10,839 Posts
ultimately the metal impeller waterpump is better. but dont think they both dont have problems, for the plastic one the fins crack and disintagrate, the metal ones have problems with the bearings
 

·
Registered
Joined
·
3,240 Posts
Originally posted by Furious@Dec 19 2003, 05:34 PM
ultimately the metal impeller waterpump is better. but dont think they both dont have problems, for the plastic one the fins crack and disintagrate, the metal ones have problems with the bearings
dont say that, as i havent had mine long :lol: :lol:
 

·
Registered
Joined
·
126 Posts
Discussion Starter #8
no maple syrup scent, we looked under the hood, there wasnt anything out of place, no smoke or wierd sounds or smells, the strange thing is that right after we looked under the hood and started to drive away, the gauge went back to normal :wrench , then it went red in a few minutes then back, it seemed like when we went on hills the redness started to occur....i was chilling w/this guy again today and he told me it was still happening!!! is he justa moron for driving with that shit, or do u guys think it just some minor bullshit???
 

·
Registered
Joined
·
1,751 Posts
you got yourself a thermo-gyro-glitero problem..........................................in other words, it's the thermo-stat. Do a TS swap, but don't get a damn autozone part, get one from pelicanparts.com (which sells BMW PARTS DIRECT) or your local dealer. :wrench
 

·
Registered
Joined
·
38 Posts
Everyone is right, start with the thermostat and go from there. It might fix the problem for minimal $. Another place to get a thermostat for less than the dealer is at www.bavauto.com. Same stamping as factory, I was very happy with mine. My .o2 would be to flush the radiator and refill with fresh stuff and change both radiator hoses while you're in there. They probably need it anyway and it will give your buddy some more peace of mind and eliminating more possibilities at the same time! Plus they're much easier to get to when you've got it apart anyway.

Not a tough job, I found the whole thing much easier than working on the wife's Ford! :confused
 

·
Registered
Joined
·
397 Posts
I'd be inclined to agree with everybody's thoughts on the thermostat, that sounds like a good place to start, but the failure mode you are describing sounds to me like its the water pump. Most cars, when the water pump just starts to go, seem fine around town, low throttle, low power driving. But the second you get it out on the highway, or begin tromping on it, the temp goes up.

I think he's in the early stages of water pump failure. Do the thermostat first, and if that dosen't work, you know its the pump.

:bravo
 
1 - 12 of 12 Posts
Top