BMW Werkz banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I am having problems with my park/ tail lights staying on all the time. I had removed the some panels under the dash in preperation for a remote starter install. I think it is in the ribbon cable that feeds the light switch. From what I can figure out the park lights run on a constant ground and If I have a bad connection they will stay on. Can anyone confirm this?

Does anyone have any wiring schematic for the park lights on this vehicle or a possible cause of this problem. I took the battery cables off for 1/2 hour and then touched them together as advice by another mechanic, but it didn't help.

Any help would be appreciated!

Thanks!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Bad connection still need park light wire!!!

realoem.com starts X3 info at 2006

Found the problem. It was a bad connection in the ribbon cable leading from the light module to the light switch. There were a few wires that were not continuous from one plug to the other.

Now that I fixed the problem I have to find out which of these 10 wires in the ribbon cable is for the park lights to continue the remote install. I really don't want to take apart the plug connection and try the process of elimination. Does anyone know which wire controls park lights. I read a forum for another BMW and they were saying it was #7. Can anyone confirm this or save me from cutting it if it is wrong.

Thank You!
 
1 - 4 of 4 Posts
Top