BMW Werkz banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I accidently posted this in the wrong 330 forum.

Thanks in advance for any helpful advice here.

I have a 2004 330 with 116,000 miles. The car runs fine. When I start the car in the morning, the car will go into reverse (automatic transmission), but when I put it into drive, it doesn't want to engage. It will take about 10-15 seconds before it engages. If I let the car warm up, it will normally engage at the get go or in 2-3 seconds. I live in south texas so it's not very cold here overnight (40, 50f) worst. Once you have the car warmed up and the transmission is engaged it is fine the rest of the day (you can stop at a store for an hour, get back in , and there is no issue).

I took it the dealership and they said that they don't open tranmissions anymore, that "slippage was minor", and that it's basically just a sign that the transmission is going to fail at some point, but when that is is anyone's guess (2 months - 2 years).

My question is, do the experts and readers on this forum agree with the dealership assessment or are there other things I can do to fix this? I don't want to sink multiple thousands into this car at this point, my base plan is to just drive it back to work and back and hope it holds out, and then sell it for scrap once the transmission goes.

This issue has been going on for about 3-4 months now, and doesn't appear to getting any worse or better.

Appreciate any advice, feedback you can provide.

Thanks
 

·
Registered
Joined
·
1 Posts
All in all I agree with the what the dealership said, you could take the car to a mechanic and have the transmission fixed or replaced. I shouldn't cost too much as the car is pretty old. 116k miles is something after all and bmw auto transmission boxes are not know to be the most durable on the market. Considering the age and the mileage of the car it has served quite long. My advice would be to buy a new box from scrapi.com for example and take it to a mechanic to replace the old one. Considering you keep taking of the car it should server another 100k miles.
 
1 - 2 of 2 Posts
Top