BMW Werkz banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
What to do???? :conf

Ignition off; Brake lights lit, warning lights on instrument panel lit. (Engine, ABS, Etc.)

Ignition on; Everything OK. :runaway
 

·
Help from over the pond
Joined
·
3,239 Posts
More like the ignition switch (not the barrel), you have to drop the steering cowl, you will see a rectangular box with wires this is the switch, I would say the contacts are sticking, some you can undo some are sealed if its the sealed variety it has to be replaced if you have the unsealed one, open and clean with electrical contact cleaner (aerosol)
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
More like the ignition switch (not the barrel), you have to drop the steering cowl, you will see a rectangular box with wires this is the switch, I would say the contacts are sticking, some you can undo some are sealed if its the sealed variety it has to be replaced if you have the unsealed one, open and clean with electrical contact cleaner (aerosol)
Thanks guys,
I will try this ASAP.

FYI, for what it's worth, I have some new info on the problem.

If I disconnect the battery with the "ignition off" everything goes out. (I know, thats a no brainer, right.) But when I touch the wire to the post the warning lightes come on first, then there is a two or three second delay before the brake lights come on. :headsmash
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Not sure what is going on but everything is working correctly now. :screwy Had a few days of hard rain last week and early this week maybe somthing got wet.

Anyway thanks for the input. :cheers
 
1 - 8 of 8 Posts
Top