BMW Werkz banner
1 - 10 of 10 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
Well fellows I hope this isn't the end for my Beamer. I have a 1990 735il e32. I parked it last week in order to replace the cv joint and the rubber dampener on the drive shaft which I did successfully. When I parked it it had a small hesitation that may could have been a light miss. After the driveshaft overhaul I was putting the muffler back on and accidentally pulled on the o2 sensor wire but did not break it. So I thought nothing of it and putit all back together and went out to drive it. It drove fine but still had this annoying little miss. Well after draining the capacitor out of the computer by connecting the two battery cables and playing with plug wires and pulling plugs and putting them back in the Beamer is running pretty shitty. Rough idle and acceleration sounds like it's drowning the motor out. One other thing I've noticed is that the exhaust will push a piece of cardboard off the muffler and then suck it back up against it. My dad believes it's the timing Chain has jumped but is not sure. I've got a new 02 sensor but I'm not sure if it will fix it. It has a new distributor cap and rotor button on it so those possibilties can be eliminated. However I have been mixing and matching old plug wires. Any ideas I hope this isn't it for my baby however she does have 250,000 miles on it. Any ideas would be greatly appreciated.
Thanks,
beamers4life
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #5 ·
My distributor cap has the nodes numbered on it and i followed it just like it said to do. Starting at the top 246-coil-315. I still have the problem however the car runs great from 1000 to 2000 rpms. I did try 153-coil-624 but the car wont start. That was a good thought however. One other thing i have noticed is that the exhaust that comes out smells really rich of gasoline vapors. Any more thoughts.
Beamers4life
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #7 ·
ok i removed the air cleaner and i still have the same problem wire connections to the flow meter seem ok not sure about the 02 sensor relay do you know which one it is. Thanks a ton for the help darkhorse.
 

·
Help from over the pond
Joined
·
3,239 Posts
Have you installed the new o2 sensor yet?
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #9 ·
Well boys i have fixed the problem. I went to the autoparts place here in town and was going to order plug wires for the car. The guy at the counter pulled it up and looked at me with big eyes and said 211 dollars. I almost dropped one in my pants right there. He then proceeded in telling me that i should probably buy some new spark plugs and try that out. I hesitated at the idea because i had just put six new bosch platinum 2's in about 10,000 miles ago.He said that as long as I had been pulling the plug wires out by the boot instead of the wire then i should still be fine regardless of the miles. So I then told him hell with it just give me six of your champions which are a cheap plug but at least not autolite. So I went home and was anxious just to see if it would work and threw the new plugs in. Voila car started right up and idle returned to stability somewhat and it doesnt drown out at 3000+ rpms. I actually pulled of 140 mph in it at a local highway. Well the problem is fixed and I owe many thanks to darkhorse and marti5 for their great suggestions which helped me uncover that i need to replace several parts in the near future. However I have a bone to pick with bosch. These plugs lasted nowhere near a year or their mileage guarantee and the plug in my #4 cylinder siezed and left some of its threads in the threads for the plug. For being a highly advertized plug and being called one of the best they are quite shitty plugs. What high end plugs would or do yall use in your beamers i wanna put some high end ones in but all i can think of is bosch. Once again darkhorse and marti5 i really appreciate you taking the time to answer my post and i will put that 02 sensor in tomorrow.
Thanks again
beamers4life
 
1 - 10 of 10 Posts
Top