BMW Werkz banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey all,
I have a strong '01 540i 6sp car that I love. Had it over 6 years, now has
180k miles. Alternator went south 2 weeks ago, took it to a dealer in NC for replacement. $1400 later a New alternator, and had a leaking power steering hose replaced.
After I picked it up from the dealer I could here a whine from what sounds like coming from the driver side front under the hood when the car is under load. Sitting still in neutral you can rev the engine with no noise. Pulling off under load from 1500 rpm and on up it has an inconsistant high pitch whine. I took it back to the dealer, they could not identify the cause, did a complimentary transmition service and told me to drive it for a couple of hundred miles and see if this helps. Now over 500 miles and the whine is still there, it does seem to follow engine load and steering ( louder when steering in lower gears) Th whine seems to go away in 5th and 6th gear at higher speeds.
This car means alot to me. Any guidance will be appreciated.
 

·
Help from over the pond
Joined
·
3,239 Posts
Sounds to me like the power steering pump, check the fluid level to start with.
 

·
Registered
Joined
·
8 Posts
I have a strange noise that starts ONLY at 1500 rpm but goes away around 2000 rpm and only when moving. In neutral and rev up to 1500 rpm and nothing. Mine sounds almost metallic. I wonder if it is really a whine and not a metallic noise. Folks think it could be heat shields, cat hanger, etc.

I have tried almost everything and found nothing. If you find the answer please post so I can cure my problem.
 
1 - 3 of 3 Posts
Top