2002 525i temp gauge pass "middle mark" regularly - BMW Forum - BimmerWerkz.com
5-Series (E12,E28, E34, E39, E60) Chat relating to the BMW 5-Series of all generations. Specific models include: BMW 518, BMW 520, BMW 520i, BMW 530i, BMW 528i, BMW 530i, BMW 518i, BMW 524d, BMW 525i, BMW 525e, BMW 528e, BMW 540i, BMW 535i, BMW 520d, BMW 525td, BMW 525d, BMW 530d, BMW 525i/xi, BMW 530i/xi. (BMW 5-Series Forum)

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-26-2019, 10:24 PM Thread Starter
n00b
 
Join Date: Jul 2009
Location: TX
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
My525i is on a distinguished road
(Thread Starter)
2002 525i temp gauge pass "middle mark" regularly

Recently replaced water pump, and two weeks ago replaced the fan behind the grille since it stopped working.

Now every time I drive for about 10 minutes the temp gauge will pass the middle mark(6 o'clock position), and then gradually go back to the middle mark. If I continue to drive longer the temp gauge will swing back and forth between the middle mark(6 o'clock position) & the 8 o'clock 10 minutes position.

Coolant is full, no leaking, fan behind the radiator is also working.

Any clue what causes this situation, or any chance the temp gauge is not working properly?

Thanks.
My525i is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-07-2019, 08:58 PM
n00b
 
Join Date: Aug 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Cộng Kip is on a distinguished road
Send a message via AIM to Cộng Kip Send a message via MSN to Cộng Kip Send a message via Yahoo to Cộng Kip
Your article is great
Cộng Kip is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > 5-Series (E12,E28, E34, E39, E60)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome