water pump froze in housing 1.9 - BMW Forum - BimmerWerkz.com
Z3 / Z4 /ZM BMW Z3 Forum & BMW Z4 Forum - Covers all the past and present Z3/Z4 vehicles including: BMW Z4 Coupe 3.0si, BMW Z4 Roadster 3.0i, Z4 Roadster 3.0si, and the ZM Coupe and Roadster (BMW Z4 Forum, BMW Z3 Forum, BMW ZM Forum)

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 10-22-2010, 09:18 AM
n00b
 
Join Date: Oct 2010
Location: Fla
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
havenh is on a distinguished road
(Thread Starter)
water pump froze in housing 1.9

I have tried to pull my water pump out according to the Bentley instructions but it was so froze that the edges broke off. I was doing it slow. Have tried everything-rubber mallet, twist, etc. Afraid to try heat. any ideas.
Thanks
havenh is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-22-2010, 03:20 PM
n00b
 
Join Date: Oct 2010
Location: Fla
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
havenh is on a distinguished road
(Thread Starter)
water pump stuck z3 1.9

After over three weeks of pulling, cutting, pounding, and grinding I got my pump loose. The Bentley book said you were simply supposed to turn two bolts and it would slide out. But that doesn't work if you have a lot of corrosion in the housing. It was stuck in so hard that even with 3 weeks of PB blaster it wouldn't budge. It only moved after I had destroyed half the pump shell(which was pretty well corroded anyhow) I should have pulled it at 60,000 instead of 100,000 miles.
Anyway hopefully just got the easy work now. Belts, thermostat, flush, and install new water pump.
Attached Thumbnails
Click image for larger version

Name:	IMAG0235.jpg
Views:	446
Size:	757.8 KB
ID:	29515   Click image for larger version

Name:	IMAG0242.jpg
Views:	360
Size:	658.1 KB
ID:	29516   Click image for larger version

Name:	IMAG0230.jpg
Views:	366
Size:	552.7 KB
ID:	29517  
havenh is offline  
#3 (permalink) Old 10-22-2010, 03:34 PM
OMFG another one!?
 
witeshark's Avatar
 
Join Date: Aug 2004
Location: Miami FL
Posts: 14,699
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice witeshark is just really nice
Nice of you to share this, thanks! In the future other members are bound to appreciate it!

BMW

Sig by zeaq
witeshark is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > Z3 / Z4 /ZM


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
E38 98 or under water pump for non water cooled alternators brand new AlpineSixAndSeven OEM Parts 0 10-12-2007 03:58 PM
540 - Water Leak - Radiator? Exp Tank? Water Pump? windarra 5-Series (E12,E28, E34, E39, E60) 2 06-09-2006 10:13 PM
water pump again bimmer3214 3-Series (E36) 9 01-26-2006 09:03 PM
Water Pump '93 93 325i 3-Series (E36) 5 09-22-2004 01:23 PM
Leaky Water pump or the Themostat Housing RedBeemer95 3-Series (E36) 12 08-21-2004 07:13 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome