Service Engine Soon - BMW Forum - BimmerWerkz.com
X Series BMW X3 Forum - Covers all the past and present X vehicles including: X3, X5, X6

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-01-2009, 06:04 PM
n00b
 
Join Date: May 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
niif is on a distinguished road
(Thread Starter)
Service Engine Soon

Earlier today I was on the motorway testing a '04 x5 at relatively high speeds around 110-120mph. As I ended my run and came to a complete stop at an intersection, I downshifted (tiptronic transmission) from 3rd or 4th to 1st and my engine started making a strange sound. The entire car started shaking and the RMPs were jittering in between the 500 to 1000 range. I shifted to the auto transmission to see if it would help but nothing changed. I put it in park, turned the car off and back on, but the problem persisted. This happens every time I accelerate in between 0-20 mph, as well as when I am idling. At one point earlier today, the rmps halted at flat 0. Everything seems to be fine driving above ~20 mph. Also the service engine soon light continues to stay on. It has been on for about 3 days but I stated noticing problems a few hours ago. Has anyone shared these experiences or have suggestions to the cause/solution of this problem? Thanks

Also, I bought this car used 1 month ago under CPO warranty at BMW dealership. I will take my car in for service as a last resort but time is of the essence right now.

Last edited by niif; 05-01-2009 at 06:09 PM.
niif is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-01-2009, 07:05 PM
Neutral Member
 
jayy781's Avatar
 
Join Date: Feb 2009
Location: Chicago
Posts: 50
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
jayy781 is on a distinguished road
At least your car ran ha, mine did the same thing but i just didnt drive it to test the limits. i just did a complete tune up and had a bad fuel pump so had that replaced, but now it runs like a champ

Good luck
jayy781 is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > X Series


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
engine service nino1372 New Members Check In 2 12-29-2008 01:38 PM
Engine Odor & Service Engine Soon Light 2004 330Ci texas23 3-Series (E46, E90) 1 06-06-2008 09:31 AM
Service Engine Soon junchoi 3-Series (E46, E90) 16 08-11-2005 04:31 PM
Service Engine Soon e55 5-Series (E12,E28, E34, E39, E60) 0 05-04-2004 04:39 PM
Service Engine Soon tknesek 1,6,7,8 - Series and Mini Cooper 1 02-08-2004 12:51 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome