Rear Windshield Wipers not working? - BMW Forum -
X Series BMW X3 Forum - Covers all the past and present X vehicles including: X3, X5, X6

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-19-2009, 08:40 PM Thread Starter
Join Date: Nov 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sidd0123 is on a distinguished road
(Thread Starter)
Rear Windshield Wipers not working?

I turned on my rear windshield wipers for my 2003 BMW X5, and they stopped working in the middle of a swipe. It has been getting stuck and lurching forward and then stopping and lurching forward for sometime now. Ive heard that a jam protection could come on if that happens? I checked like 10 minutes later on just battery power, but they didnt work. What else could it be, and what can i do at home to save some money.
sidd0123 is offline  
Sponsored Links

  BMW Forum - > BMW Model Specific Forums > X Series
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield wipers not working watatrp 3-Series (E46, E90) 0 12-22-2006 06:22 AM
Windshield Wipers Wade6923 5-Series (E12,E28, E34, E39, E60) 8 04-15-2005 11:51 PM
Windshield Wipers wannabedivers 5-Series (E12,E28, E34, E39, E60) 0 10-20-2004 11:16 AM
windshield wipers quinoskar 5-Series (E12,E28, E34, E39, E60) 3 01-18-2004 12:04 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome