2008 X3 start / rough idle problems - BMW Forum - BimmerWerkz.com
X Series BMW X3 Forum - Covers all the past and present X vehicles including: X3, X5, X6

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-21-2012, 02:37 PM
n00b
 
Join Date: Dec 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
GlassHalfFull is on a distinguished road
(Thread Starter)
2008 X3 start / rough idle problems

X3 will not start. Engine turns over but will not start. I run a diagnostic on it and it shows a P1056 code along with a few other similar vvt codes. I continued to try cranking it, it eventually started up and displays the brake / 4x4 / dtc lights and runs rough and will not rev over 2k. I disconnect the battery. I had the battery tested and it is fine. after re installing the battery the car cranks and runs fine. So the car runs ok for a few days. Then back to the same, no start, eventually starts but runs rough and rpm wont go over 2k. Remove battery terminal, replace, Car starts and acts fine. What does this sound like? The car usually does run slightly rough when cranked on a cold start in the morning. I'm thinking there could either be something to Due with the VVT module or Camshaft Pos sensor. The car has 70k. I had an o2 code a couple of months back but I replaced the spark plugs and it remedied the o2 problem. So I just took the battery terminal off put it back on and everything is fine again Any thoughts???
GlassHalfFull is offline  
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > X Series


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough idle and Loud ping upon start-up bcain79 5-Series (E12,E28, E34, E39, E60) 3 03-02-2012 01:41 PM
1998 528 rough idle at cold start wheelie 5-Series (E12,E28, E34, E39, E60) 0 05-13-2009 09:05 PM
Need diagnosing help on 99 M3 E36, Rough Idle, Cold Start Issues kazamali 3-Series (E36) 8 04-22-2009 04:00 PM
1997 328i Rough Idle on Cold Start Larry Horne 3-Series (E36) 14 01-25-2006 12:09 AM
Rough Idle At Start Only - Once Hot Runs Fine streetdreams 3-Series (E36) 1 11-30-2004 12:55 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome