2005 X5 Key in ignition signal, and more - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > X Series
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

X Series BMW X3 Forum - Covers all the past and present X vehicles including: X3, X5, X6

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-27-2012, 12:48 PM   #1 (permalink)
n00b
 
Join Date: Nov 2012
Car:
Posts: 1
Photos:
euroah is on a distinguished road
2005 X5 Key in ignition signal, and more

2005 X5 came in after customer reportedly left the sunroof open and the vehicle got rained in. Symptoms were: Hazard lights start flashing randomly while driving or parked , the "key in ignition" signal stays on the instrument cluster sometimes after key is removed, and sometimes the door locks do not work the first time with the key remote ( the alarm seems to arm as the running lights do flash) but they do work the second time the remote button is pushed (unlock and then lock again). We thought that the hazard light problem was a no brainer, assuming that water had entered the hazard/door lock switch and replaced it. My tech assumed the "key in ignition" signal was generated by the ignition switch and replaced it. While seemingly the hazard light problem was fixed, the "key in ignition" signal was still intermittent. After finding out that the "key in ign" signal is generated by the EWS module by seeing the key still transmitting via the ring antenna, we tried a new EWS module, no change. We then found that this signal apparently goes (over the K-bus) from the EWS to the LCM, and then to the IKE. So we tried a used LCM and my tech told me the problem was solved. I ordered a new LCM, coded it to the car (myself) and still had the same problem. I'm not sure why it didn't act up for my tech with the used LCM. I put the used LCM back in and had the same problem. Thought maybe the order in which the connectors on the LCM are connected may change something and tried all combinations, no change. We tried a different ZKE and IKE, no change. We also, out of desparation, tried a new ring coil antenna, no change. We did figure out that if you pull the key out before opening the door, the "key in ign" signal seems to work correctly every time, although the customer says that even when he exits the car after pulling the key before opening the door, the door lock problem still happens sometimes. I can reproduce the door lock problem every time by opening the door first, then pulling the key out which causes the "key in ignition" signal on the cluster that won't go away, and then trying the door locks via the remote. Interestingly, I also found that if you turn the key off and pull it out quickly, before terminal R power goes away, it seems to work correctly, even if the door is already open. All of the signals from the LF door module look correct on the autologic. The customer needed the car for awhile, but we are getting it back soon. He said that the Hazard light problem is still there also. Any thoughts or help would be extremely appreciated. Greg
euroah is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BMW Model Specific Forums > X Series


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 BMW ignition circuit ferganskie X Series 1 09-03-2010 08:59 AM
2005 BMW M3 - or - 2005 Porsche 911 Carrera S? steve123 3-Series (E46, E90) 8 09-13-2004 07:04 PM
Any new pics of 2005 M3 or 2005 330? Bimmer2004 M-Series (M1, M3, M5, M6) 12 07-29-2004 01:11 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 05:12 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.