po340 - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BimmerWerkz > New Members Check In
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

New Members Check In come in say hello...

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-17-2012, 12:45 AM   #1 (permalink)
n00b
 
Join Date: Dec 2012
Location: ny
Car: 99 328i e46
Posts: 7
Photos:
JLynch is on a distinguished road
po340

i was driving my 99 328i all day and later took it on the highway. It stalled about 15 minutes into the ride. Pulled over waited a few then started it. The car was idling extremely rough. I drove it off the highway and it wouldn't go over 30mph. Lot of hesitation. I ran the codes when I towed it home and there were several. po300,p1522 and 340. The engine had a diesel like sound to it. I read some blogs and took care of some things;plugs, rebuilt vanos with beisan seals and bearings,changed intake and exhaust sensors. car starts fine but runs rough with no power. I did disconnect the intake sensor plug and there was no change to the way it ran. I also took out the ecm and inspected it and there was no corrosion. I am baffled, some one please help cause i'm getting deep.I erased all the codes after the maintenance and the only one that comes back is po340
JLynch is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-17-2012, 11:15 PM   #2 (permalink)
n00b
 
Join Date: Dec 2012
Location: ny
Car: 99 328i e46
Posts: 7
Photos:
JLynch is on a distinguished road
Need Help!

Does anyone one have any Idea what I need to do next?
JLynch is offline   Reply With Quote
Old 12-18-2012, 08:00 AM   #3 (permalink)
1st Gear Member
 
Ivan413's Avatar
 
Join Date: Nov 2012
Location: NY
Car: 95 BMW 318i
Posts: 177
Photos:
Ivan413 is on a distinguished road
Garage
I'm not sure what code po34


Sent from my iPhone using AutoGuide.com Free App
__________________
Just your avg 17 year old with an e36 318i as a DD!
Ivan413 is offline   Reply With Quote
Old 12-18-2012, 08:01 AM   #4 (permalink)
1st Gear Member
 
Ivan413's Avatar
 
Join Date: Nov 2012
Location: NY
Car: 95 BMW 318i
Posts: 177
Photos:
Ivan413 is on a distinguished road
Garage
Po340 is but It sounds like ur car went into limp mode. Have u tried unplugging the maf sensor and seeing If the idling got any better.


Sent from my iPhone using AutoGuide.com Free App
__________________
Just your avg 17 year old with an e36 318i as a DD!
Ivan413 is offline   Reply With Quote
Old 12-18-2012, 10:02 AM   #5 (permalink)
n00b
 
Join Date: Dec 2012
Location: ny
Car: 99 328i e46
Posts: 7
Photos:
JLynch is on a distinguished road
po3340 is the Camshaft position sensor circuit malfunction.
By the way I have tried disconnecting the MAF sensor and it did not make any difference. Thanks
JLynch is offline   Reply With Quote
Old 12-18-2012, 10:49 AM   #6 (permalink)
1st Gear Member
 
Ivan413's Avatar
 
Join Date: Nov 2012
Location: NY
Car: 95 BMW 318i
Posts: 177
Photos:
Ivan413 is on a distinguished road
Garage
You replaced the sensor correct?


Sent from my iPhone using AutoGuide.com Free App
__________________
Just your avg 17 year old with an e36 318i as a DD!
Ivan413 is offline   Reply With Quote
Old 12-18-2012, 12:34 PM   #7 (permalink)
n00b
 
Join Date: Dec 2012
Location: ny
Car: 99 328i e46
Posts: 7
Photos:
JLynch is on a distinguished road
I changed the camshaft intake and exhaust sensors
JLynch is offline   Reply With Quote
Old 12-18-2012, 12:44 PM   #8 (permalink)
1st Gear Member
 
Ivan413's Avatar
 
Join Date: Nov 2012
Location: NY
Car: 95 BMW 318i
Posts: 177
Photos:
Ivan413 is on a distinguished road
Garage
There might be a problem with your wiring...possible short or corrosion in the harness somewhere. Have you checked it already?


Sent from my iPhone using AutoGuide.com Free App
__________________
Just your avg 17 year old with an e36 318i as a DD!
Ivan413 is offline   Reply With Quote
Old 12-18-2012, 12:56 PM   #9 (permalink)
n00b
 
Join Date: Dec 2012
Location: ny
Car: 99 328i e46
Posts: 7
Photos:
JLynch is on a distinguished road
Not quite sure how to get at it.
JLynch is offline   Reply With Quote
Old 12-18-2012, 01:51 PM   #10 (permalink)
1st Gear Member
 
Ivan413's Avatar
 
Join Date: Nov 2012
Location: NY
Car: 95 BMW 318i
Posts: 177
Photos:
Ivan413 is on a distinguished road
Garage
I'm not exactly sure where this is located in your bmw but the sensor should have 3 different wires coming from it. That error code is related to the wiring of the sensor. So I'm guessing it has to be a short in one of the three wires or there's to much or to little resistance in the power (volts) if you have a volt meter you can check to see how much power your sensor is receiving.


Sent from my iPhone using AutoGuide.com Free App
__________________
Just your avg 17 year old with an e36 318i as a DD!
Ivan413 is offline   Reply With Quote
Old 12-18-2012, 09:04 PM   #11 (permalink)
n00b
 
Join Date: Dec 2012
Location: ny
Car: 99 328i e46
Posts: 7
Photos:
JLynch is on a distinguished road
decided to take coil plugs off individually while vehicle was running and found that #5 and #6 did not effect the idle.
JLynch is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BimmerWerkz > New Members Check In


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:55 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.