newbie that needs HELP!! FROM CALI! - BMW Forum - BimmerWerkz.com
BMW Forum BMW Forum

» Auto Insurance

» Featured Product
» Wheel & Tire Center

Go Back   BMW Forum - BimmerWerkz.com > BimmerWerkz > New Members Check In
Register Home Forum Active Topics Gallery / Showroom Auto Loans Garage Search Today's Posts Mark Forums Read Auto EscrowInsurance

New Members Check In come in say hello...

BimmerWerkz.com is the premier BMW Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-06-2010, 02:39 AM   #1 (permalink)
n00b
 
Join Date: Apr 2010
Car:
Posts: 4
Photos:
hvmsantos is on a distinguished road
newbie that needs HELP!! FROM CALI!

im new here. have lots of questions.. just got the e36 328i that wont pass smog.. the code comes up p0111. i just replaced the intake air temp sensor.. and the engine light still comes on.. i'm thinkin about replacin the maf. what if its not that and the wires. how do i know what to fix.. how do i inspect the wiring or connections.. what about the throttle when the car is off is that metal piece in the middle suppose to be half way open or closed.. any pix of wiring or throttle .. thanks sooo much! i'm so confuse!! please help THANKS!
hvmsantos is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-06-2010, 05:36 AM   #2 (permalink)
42, The meaning of life
 
brettski's Avatar
 
Join Date: Jul 2009
Location: Melbourne, Australia
Car: 2000 740iL Individual
Posts: 2,405
Photos:
brettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nice
Welcome to the Werkz. Someone here will be able to give you some more specific help.

One way to check your MAF is to simply disconnect it and see if the performance of the car changes at all. If it get better then your MAF may be shot, you can sometimes clean them up with Brake Cleaner, but remove it from the car before you so that.
How long has the engine light been on for? Are there any performance issues with the car? The injectors could be clogged, dirty fuel filter reducing fuel rail pressure, blocked air filter, stuffed O2 sensors.
Good luck
brettski is offline   Reply With Quote
Old 04-06-2010, 08:55 AM   #3 (permalink)
Mr. Clean
 
BimmerE39's Avatar
 
Join Date: Jan 2009
Location: Danbury, Connecticut
Car: Titanium Silver E39 / 2011 BMW M3
Posts: 1,817
Photos:
BimmerE39 will become famous soon enough
Garage
P0111 is the code for the intake air temperature circuit soy you did get that right at the very least. Have any other codes popped up like P1188 or P1189? Have you suffered from any misfires? On another note I'd like to say California's emission laws SUCK.
__________________
BimmerE39 is offline   Reply With Quote
Old 04-06-2010, 10:01 AM   #4 (permalink)
Ich bin der Modifikator
 
johnnyBgood's Avatar
 
Join Date: Sep 2007
Location: Bayonne, NJ
Car: 97'E36 2.8 w/Optional Sport Package
Posts: 3,325
Photos:
johnnyBgood is a jewel in the roughjohnnyBgood is a jewel in the roughjohnnyBgood is a jewel in the rough
Garage
Quote:
replaced the intake air temp sensor.. and the engine light still comes on..

Question, after you replaced the intake air temp sensor, did you have the CEL cleared? You have to actually have the code cleared.......


jb
__________________
______________________________________
_______________________97 E36|Conforti Software|M50 Manifold|AFE|Borla|H&R| Bilstein |Eibach|Rockford|3.15 LSD
____________________________________________http://www.cardomain.com/ride/3129109
johnnyBgood is offline   Reply With Quote
Old 04-06-2010, 10:12 AM   #5 (permalink)
n00b
 
Join Date: Apr 2010
Car:
Posts: 4
Photos:
hvmsantos is on a distinguished road
yes. my codes got cleared but after driving thirty miles i turn off the car. ck w/ the obd11 then it pops up again.. i dont know bout wiring.. but i will ck it out today.. thanks for all ur wonderful advise!! but if u have more pls let me knw... i'm been fixing this car all month... there was alot of thing wrong. cyldiner misfire 1,2,3 oxy sensor, and intake air temperature and engine light on.i changed the transmission. spark plugs. fan. fan shroud. radiator. oxy sensor. cooling. a/c.. did sooo much i'm sooo broke and depress. i just cant get this last thing off p0111.. i'm totally stresssssss pls help.
hvmsantos is offline   Reply With Quote
Old 04-06-2010, 10:14 AM   #6 (permalink)
n00b
 
Join Date: Apr 2010
Car:
Posts: 4
Photos:
hvmsantos is on a distinguished road
Quote:
Originally Posted by brettski View Post
Welcome to the Werkz. Someone here will be able to give you some more specific help.

One way to check your MAF is to simply disconnect it and see if the performance of the car changes at all. If it get better then your MAF may be shot, you can sometimes clean them up with Brake Cleaner, but remove it from the car before you so that.
How long has the engine light been on for? Are there any performance issues with the car? The injectors could be clogged, dirty fuel filter reducing fuel rail pressure, blocked air filter, stuffed O2 sensors.
Good luck
... how do i rmove the maf and perform test to find out?
hvmsantos is offline   Reply With Quote
Old 04-06-2010, 10:00 PM   #7 (permalink)
42, The meaning of life
 
brettski's Avatar
 
Join Date: Jul 2009
Location: Melbourne, Australia
Car: 2000 740iL Individual
Posts: 2,405
Photos:
brettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nicebrettski is just really nice
Not sure on your model, but on mine it was a simple 3 pin wiring connector that disconnects from the MAF body. The Engine Management goes into a default mode because its got no feedback and hopefully will give you something to work with. Good luck.
brettski is offline   Reply With Quote
Old 04-06-2010, 10:53 PM   #8 (permalink)
n00b
 
Join Date: Apr 2010
Car:
Posts: 4
Photos:
hvmsantos is on a distinguished road
well i just replaced my old maf w/ a used one. replaced the air intake temp sensor.. replaced a few vacuum hose still my light comes on. please help what am i doing wrong??
hvmsantos is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  BMW Forum - BimmerWerkz.com > BimmerWerkz > New Members Check In


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello From Cali BMW325ad New Members Check In 2 03-31-2009 01:09 AM
hello from cali!!!!!!! hunter325i New Members Check In 6 01-05-2007 12:49 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:13 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.